Bug 962412 - spinner doesn't stop when you select the organization tab (Administer-> organization)
spinner doesn't stop when you select the organization tab (Administer-> organ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
high Severity unspecified (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 08:01 EDT by Sachin Ghai
Modified: 2013-07-18 17:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:20:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spinner keeps on rotating when you select the organization tab. (35.05 KB, image/png)
2013-05-13 08:01 EDT, Sachin Ghai
no flags Details
created a new org test_org and redirected page just displayed the org name (22.62 KB, image/png)
2013-05-13 08:06 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Sachin Ghai 2013-05-13 08:01:56 EDT
Created attachment 747196 [details]
spinner keeps on rotating when you select the organization tab.

Description of problem:
spinner keeps on rotating when you select the organization tab. UI doesn't display none of the newly added  and default (ACME_Corporation) org under organization's left pane.

Version-Release number of selected component (if applicable):

katello-1.4.2-1.git.313.0d31cdb.el6.noarch

How reproducible:
always 

Steps to Reproduce:
1. Select the Administer-> Organization
2. 
3.
  
Actual results:
spinner doesn't stop when you select the organization tab (Administer-> organization)

Expected results:
The Left pane of Organization tab should show the newly added or default org(ACME_Corporation) name.


Additional info:
Browser FF-17.0.5
Comment 1 Sachin Ghai 2013-05-13 08:05:21 EDT
when user creates a new org then UI redirects to page that just displays 'org name'. please see the 2nd attachment.
Comment 2 Sachin Ghai 2013-05-13 08:06:46 EDT
Created attachment 747197 [details]
created a new org test_org and redirected page just displayed the org name
Comment 3 Og Maciel 2013-05-13 09:50:19 EDT
It's a jscript issue:

  TypeError: t is undefined
    https://tyan-gt24-13.rhts.eng.bos.redhat.com/katello/assets/common-08f1e70a7566929504f6c2123285f32b.js
    Line 25

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.7-1.el6.noarch
* candlepin-cert-consumer-tyan-gt24-13.rhts.eng.bos.redhat.com-1.0-1.noarch
* candlepin-selinux-0.8.7-1.el6.noarch
* candlepin-tomcat6-0.8.7-1.el6.noarch
* elasticsearch-0.19.9-7.el6.noarch
* katello-1.4.2-1.git.313.0d31cdb.el6.noarch
* katello-all-1.4.2-1.git.313.0d31cdb.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-1.el6.noarch
* katello-cli-1.4.2-1.git.47.c7ac869.el6.noarch
* katello-cli-common-1.4.2-1.git.47.c7ac869.el6.noarch
* katello-common-1.4.2-1.git.313.0d31cdb.el6.noarch
* katello-configure-1.4.3-1.git.12.bc3684c.el6.noarch
* katello-glue-candlepin-1.4.2-1.git.313.0d31cdb.el6.noarch
* katello-glue-elasticsearch-1.4.2-1.git.313.0d31cdb.el6.noarch
* katello-glue-pulp-1.4.2-1.git.313.0d31cdb.el6.noarch
* Katello-Katello-Installation-RegisterRHNClassic-1.1-3.noarch
* Katello-Katello-Sanity-ImportKeys-1.2-1.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-repos-1.4.2-1.el6.noarch
* katello-selinux-1.4.3-1.git.3.ce8227b.el6.noarch
* openldap-2.4.23-31.el6.x86_64
* openldap-devel-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.1-0.10.beta.el6.noarch
* pulp-selinux-2.1.1-0.10.beta.el6.noarch
* pulp-server-2.1.1-0.10.beta.el6.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.1.3-4.el6.noarch
* ruby193-rubygem-net-ldap-0.2.2-6.el6.noarch
Comment 4 Og Maciel 2013-05-13 10:02:21 EDT
Same happens with Users management page
Comment 5 Tom McKay 2013-05-13 10:17:15 EDT
Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: 4ecb8c0c0a6f62aaa682062dd4197b1d8ef9c6a4
      https://github.com/Katello/katello/commit/4ecb8c0c0a6f62aaa682062dd4197b1d8ef9c6a4
  Author: David Davis <daviddavis@redhat.com>
  Date:   2013-05-13 (Mon, 13 May 2013)
Comment 6 Sachin Ghai 2013-05-15 05:52:14 EDT
The reported issue is fixed, verified with following version:
katello-1.4.2-1.git.333.d2a35bc.el6.noarch
Comment 7 Sachin Ghai 2013-05-17 03:21:08 EDT
Moving to verified as per comment6.
Comment 8 Mike McCune 2013-07-18 17:20:47 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.