Bug 962658 - Out of order messages with grouping after failover
Out of order messages with grouping after failover
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: HornetQ (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity medium
: ER7
: EAP 6.1.1
Assigned To: Andy Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 03:47 EDT by Andy Taylor
Modified: 2013-09-16 16:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 16:22:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker HORNETQ-1194 Major Resolved out of order on failover 2017-07-11 06:04 EDT

  None (edit)
Description Andy Taylor 2013-05-14 03:47:08 EDT
There is a small possibility that when message grouping is used that if messages are out for delivery when failover occurs that they maybe received out of order.
Comment 1 JBoss JIRA Server 2013-05-14 07:44:11 EDT
Andy Taylor <ataylor@redhat.com> updated the status of jira HORNETQ-1194 to Resolved
Comment 3 Miroslav Novak 2013-08-22 09:37:41 EDT
BZ is in incorrect state. Fix for this issue is present in EAP 6.1.1.ER7(HQ 2.3.5.Final) 

Verified using provided test in EAP 6.1.1.ER7. Great work, Andy!
Comment 4 Rostislav Svoboda 2013-08-26 06:11:48 EDT
Removing jboss-eap-6.2.0 flag because it's fixed in EAP 6.1.1

Note You need to log in before you can comment on or make changes to this bug.