Bug 962680 - [online_runtime_card310]Met "Node execution failure" when creating wordpress and magento-example quickstarts
[online_runtime_card310]Met "Node execution failure" when creating wordpress ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 04:57 EDT by Wei Sun
Modified: 2015-05-14 19:11 EDT (History)
0 users

See Also:
Fixed In Version: devenv_
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 23:57:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
wordpress (272.69 KB, text/x-log)
2013-05-14 05:00 EDT, Wei Sun
no flags Details
magento (272.20 KB, text/x-log)
2013-05-14 05:03 EDT, Wei Sun
no flags Details

  None (edit)
Description Wei Sun 2013-05-14 04:57:29 EDT
Description of problem:
Create wordpress and magento-example quickstarts as follow README.md,but it will meet "Node execution failure". Check development.log,get some error messages,like:
[[0;37m2013-05-14 04:41:49.386^[[0m [^[[31mERROR^[[0m] Node execution failure (invalid exit code from node).  If the problem persists please contact Red Hat support. (pid:2622)
[[0;37m2013-05-14 04:41:49.387^[[0m [^[[31mERROR^[[0m] ["/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.9.1/lib/openshift/mcollective_application_container_proxy.rb:2614:in `parse_result'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.9.1/lib/openshift/mcollective_application_container_proxy.rb:2762:in `run_cartridge_command'", "/var/www/openshift/broker/lib/online/broker/mcollective_ext.rb:13:in `run_cartridge_command'",

Please refer to attachement

Version-Release number of selected component (if applicable):
devenv_3224
https://github.com/openshift/magento-example
https://github.com/openshift/wordpress-example

How reproducible:
Always

Steps to Reproduce:
1.Create wordpress quickstart as follow: https://github.com/openshift/wordpress-example
2.Create magento quickstart as follow: https://github.com/openshift/magento-example
3.
  
Actual results:
1.[sunwei@dhcp-8-229 dev]$ rhc app create wordpress php-5 mysql-5 --from-code=https://github.com/openshift/wordpress-example
Using php-5.3 (PHP 5.3) for 'php-5'
Using mysql-5.1 (MySQL Database 5.1) for 'mysql-5'

Application Options
-------------------
  Namespace:   wsun3224quick
  Cartridges:  php-5.3, mysql-5.1
  Source Code: https://github.com/openshift/wordpress-example
  Gear Size:   default
  Scaling:     no

Creating application 'wordpress' ... 
Unable to complete the requested operation due to: Node execution failure (invalid exit code from node).  If
the problem persists please contact Red Hat support..
Reference ID: 97b24d30d8f5b365bfe8f4d0fc13723a

2.[sunwei@dhcp-8-229 dev]$ rhc app create magento php-5.3 mysql-5.1 --from-code=https://github.com/openshift/magento-example
Application Options
-------------------
  Namespace:   wsun3224quick
  Cartridges:  php-5.3, mysql-5.1
  Source Code: https://github.com/openshift/magento-example
  Gear Size:   default
  Scaling:     no

Creating application 'magento' ... 
Unable to complete the requested operation due to: Node execution failure (invalid exit code from node).  If
the problem persists please contact Red Hat support..
Reference ID: 5ec692732b53e9780e8b41d0b70b7d6e

Expected results:
Can create them successfully.

Additional info:
Comment 1 Wei Sun 2013-05-14 05:00:17 EDT
Created attachment 747562 [details]
wordpress
Comment 2 Wei Sun 2013-05-14 05:03:09 EDT
Created attachment 747564 [details]
magento
Comment 3 Dan McPherson 2013-05-16 23:49:17 EDT
Fixed in devenv_3237

Required quickstart and code changes.
Comment 4 Wei Sun 2013-05-17 06:37:58 EDT
Verified in devenv_3238

Can create wordpress and magento-example quickstarts successfully.

Note You need to log in before you can comment on or make changes to this bug.