Bug 962789 - Launching a Windows VM from the UP prompts the user to install virt-viewer every time it is launched (No ActiveX upgrade)
Launching a Windows VM from the UP prompts the user to install virt-viewer ev...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: spice-activex-win (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity low
: ---
: 3.2.0
Assigned To: Marc-Andre Lureau
Desktop QE
spice
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 08:58 EDT by Bill Sanford
Modified: 2016-02-10 15:21 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-16 10:13:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Spice
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Sanford 2013-05-14 08:58:46 EDT
Description of problem:
Launching a Windows VM from the UP prompts the user to install virt-viewer every time it is launched.

I get the prompt to install SpiceX_x64.cab every time I launch the VM from the UP or PUP.

I tried to reproduce this on a Windows 7 client, and the client worked as expected. 

Version-Release number of selected component (if applicable):
RHEV-M 3.2 (sf16.1)
W2K8R2 client

How reproducible:
100%

Steps to Reproduce:
1. See above. 
2.
3.
  
Actual results:
Launching a Windows VM from the UP prompts the user to install virt-viewer every time it is launched.

Expected results:
Launching a Windows VM from the UP prompts the user to install virt-viewer the first time it is launched, only.

Additional info:
Comment 3 Bill Sanford 2013-05-14 09:44:55 EDT
I have done further investigating and it seems this only happens after you connect to a previous UP, RHEV-M 3.1 was tested for upgrade in client, and then connect to a 3.2 UP.

What I saw was the UP downloading the NEW client, but never updating the SpiceX - ActiveX control. Every time the UP was loaded, the old ActiveX was there with the new v-v. And the v-v install would happen every time the VM was launched.
Comment 4 Tomas Jelinek 2013-05-15 04:22:07 EDT
Bill, if you uninstall the SpiceX first and than connect to 3.2, does it work as expected? If yes, I would say it should be moved to SPICE.
Comment 5 Bill Sanford 2013-05-15 12:55:34 EDT
Tomas, I have moved this to activex-win since the browser is not getting updated with the 3.2 SpiceX and using the 3.1 version and failing.
Comment 6 Marc-Andre Lureau 2013-05-16 07:46:59 EDT
Bill, is this a w2k8-only bug then? If yes, I think we should make that clear in the title and minor severity.
Comment 7 Bill Sanford 2013-05-16 10:13:59 EDT
I have just installed sf17 and can't get this to fail. Not sure what was changed but will close for current release.

Note You need to log in before you can comment on or make changes to this bug.