Bug 962912 - ERROR with transaction check vs depsolve:
ERROR with transaction check vs depsolve:
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 14:51 EDT by Don
Modified: 2013-05-16 02:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-16 02:59:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don 2013-05-14 14:51:37 EDT
Description of problem:
mysql-libs < 5.6.11-2.linux_glibc2.5 is obsoleted by (installed) MySQL-shared-compat-5.6.11-2.linux_glibc2.5.x86_64
 You could try running: rpm -Va --nofiles --nodigest
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2013-05-14.14-43.Pk03ja.yumtx

.. install failed!

Version-Release number of selected component (if applicable):
5.6.11-2

How reproducible:
100%

Steps to Reproduce:
1. yum install mysql-DBD-MySQL
  
Actual results:
Installing package(s) with command yum -y install perl-DBD-MySQL ..

Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package perl-DBD-MySQL.x86_64 0:4.023-1.fc18 will be installed
--> Processing Dependency: libmysqlclient.so.18(libmysqlclient_16)(64bit) for package: perl-DBD-MySQL-4.023-1.fc18.x86_64
--> Running transaction check
---> Package mysql-libs.x86_64 0:5.5.31-1.fc18 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package               Arch          Version               Repository      Size
================================================================================
Installing:
 perl-DBD-MySQL        x86_64        4.023-1.fc18          updates        139 k
Installing for dependencies:
 mysql-libs            x86_64        5.5.31-1.fc18         updates        709 k

Transaction Summary
================================================================================
Install  1 Package (+1 Dependent package)

Total size: 848 k
Installed size: 4.4 M
Downloading Packages:
Running Transaction Check
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
ERROR with transaction check vs depsolve:
mysql-libs < 5.6.11-2.linux_glibc2.5 is obsoleted by (installed) MySQL-shared-compat-5.6.11-2.linux_glibc2.5.x86_64
 You could try running: rpm -Va --nofiles --nodigest
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2013-05-14.14-43.Pk03ja.yumtx

.. install failed!

Expected results:


Additional info:
Comment 1 Jan Zeleny 2013-05-16 02:59:14 EDT
Not a bug in yum. Yum only informs you about the inability to install the package because another package being already installed. You can check details about mysql vs. mariadb packaging in fedora-devel mailing list archives.

Note You need to log in before you can comment on or make changes to this bug.