Bug 962952 - wallpaper too dark
wallpaper too dark
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: schroedinger-cat-backgrounds (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Sourada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 16:20 EDT by nucleo
Modified: 2013-05-24 16:24 EDT (History)
5 users (show)

See Also:
Fixed In Version: desktop-backgrounds-19.0.0-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 16:24:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
F19 KDE wallpaper (4.34 MB, image/png)
2013-05-14 16:20 EDT, nucleo
no flags Details
GNOME day wallpaper (4.62 MB, image/png)
2013-05-14 16:21 EDT, nucleo
no flags Details
GNOME night wallpaper (3.90 MB, image/png)
2013-05-14 16:22 EDT, nucleo
no flags Details
KDE desktop with Dawn wallpaper (1.31 MB, image/png)
2013-05-21 12:08 EDT, nucleo
no flags Details

  None (edit)
Description nucleo 2013-05-14 16:20:47 EDT
Created attachment 747902 [details]
F19 KDE wallpaper

Description of problem:
KDE wallpaper too dark (see screenshot).

Version-Release number of selected component (if applicable):
schroedinger-cat-kde-theme-18.91.5-1.fc19

Actual results:
Text on panel hard to read with dark background if transparency used.

Expected results:
There is available lighter wallpaper on GNOME live image that shown at day time, see screenshot, so it can be used as default in KDE.
Comment 1 nucleo 2013-05-14 16:21:35 EDT
Created attachment 747913 [details]
GNOME day wallpaper
Comment 2 nucleo 2013-05-14 16:22:57 EDT
Created attachment 747914 [details]
GNOME night wallpaper

GNOME night wallpaper the same as wallpaper default in KDE.
Comment 3 Martin Bříza 2013-05-15 08:36:21 EDT
Reassinging to the proper component. The wallpaper links are done in schroedinger-cat-backgrounds-kde.
Personally, I like the lighter version, too, but the dark one is set as the default one.
Comment 4 Martin Sourada 2013-05-15 16:12:33 EDT
Hi, I'm open to discussion, but I fear this might be very subjective (there are lots of people that object to lighter versions too...). Just to be sure -- there are total of four versions of the wallpaper (for the time-of-day animation purposes). Which is the one you two prefer?

https://fedoraproject.org/wiki/F19_Artwork#Alpha_Release_Wallpaper

I personally prefer the dark one (night), but I'm on XFCE and use only semitransparent panels. Since we're talking about *default*, how does it clash with *default* KDE settings? Can you (is it possible) change text colour on panel, if dark background and transparency is used?

After these questions are answered, it would be probably best to consult with design team about more opinions than just us three and make a final decision before GA.
Comment 5 nucleo 2013-05-15 16:15:56 EDT
Black text on transparent KDE panel with black background hard to read.
So the most light wallpaper is the better.
Comment 6 Martin Sourada 2013-05-15 16:39:33 EDT
(In reply to comment #5)
> Black text on transparent KDE panel with black background hard to read.
Yes, this is obvious. I'd like to know though, before making any decision, whether it's possible to change the colour of the text, and if the transparency is on by default in kde.

> So the most light wallpaper is the better.
Yeah, that makes sense in that context.
Comment 7 nucleo 2013-05-15 17:57:33 EDT
There is no simple option such as "Panel text color", this color defined by Desktop theme, so changing color not so simple as changing one of KDE default options.
Comment 8 Martin Bříza 2013-05-16 10:17:38 EDT
In my opinion, "dawn" is the best of them all but not perfect. Compared to the others, it looks a bit... well, I'd say bleached.

(In reply to comment #6)
> (In reply to comment #5)
> > Black text on transparent KDE panel with black background hard to read.
> Yes, this is obvious. I'd like to know though, before making any decision,
> whether it's possible to change the colour of the text, and if the
> transparency is on by default in kde.
> 
> > So the most light wallpaper is the better.
> Yeah, that makes sense in that context.

Well, we could change the Spherical Cow theme which is shipped with the release but I'd be much happier if the wallpaper was where the change is made because (as I wrote) I think the dawn one looks better (and isn't such a big color shift from the previous wallpaper) not mentioning it seems to be an easier change.
Comment 9 Rex Dieter 2013-05-21 11:40:40 EDT
Discussed the issue in the kde-sig meeting today and reached consensus that we'd greatly prefer using the "dawn" variant from 
https://fedoraproject.org/wiki/F19_Artwork#Alpha_Release_Wallpaper
to be used (instead of night).

Considered day, which would help visibility for us even more, but understand that level of brightness may go too far for some subjective tastes.

Does this sound like a reasonable change ?  (else, we'll have to resort to some hackery in the kde-specific theming to address it, but I'd rather not to have to do that)
Comment 10 nucleo 2013-05-21 12:08:27 EDT
Created attachment 751250 [details]
KDE desktop with Dawn wallpaper

On kde-sig meeting agreed that Dawn wallpaper will be the best.
http://meetbot.fedoraproject.org/fedora-meeting/2013-05-21/kde-sig.2013-05-21-15.07.log.html
Comment 11 Martin Sourada 2013-05-21 16:50:14 EDT
(In reply to Rex Dieter from comment #9)
> Discussed the issue in the kde-sig meeting today and reached consensus that
> we'd greatly prefer using the "dawn" variant from 
> https://fedoraproject.org/wiki/F19_Artwork#Alpha_Release_Wallpaper
> to be used (instead of night).
> 
> Considered day, which would help visibility for us even more, but understand
> that level of brightness may go too far for some subjective tastes.
> 
> Does this sound like a reasonable change ?  (else, we'll have to resort to
> some hackery in the kde-specific theming to address it, but I'd rather not
> to have to do that)

Yes, sounds reasonable. I'll make the necessary changes and builds most likely tomorrow.
Comment 12 nucleo 2013-05-22 17:47:49 EDT
Dawn wallpaper appeared in kdm, ksplash and on desktop after updating to schroedinger-cat-backgrounds-base-18.91.0-1.fc19 and schroedinger-cat-backgrounds-extras-kde-18.91.0-1.fc19 and clearing cache.
Comment 13 Fedora Update System 2013-05-22 20:12:45 EDT
desktop-backgrounds-19.0.0-2.fc19,schroedinger-cat-backgrounds-18.91.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/desktop-backgrounds-19.0.0-2.fc19,schroedinger-cat-backgrounds-18.91.0-1.fc19
Comment 14 Fedora Update System 2013-05-23 15:59:58 EDT
Package desktop-backgrounds-19.0.0-2.fc19, schroedinger-cat-backgrounds-18.91.0-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing desktop-backgrounds-19.0.0-2.fc19 schroedinger-cat-backgrounds-18.91.0-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9009/desktop-backgrounds-19.0.0-2.fc19,schroedinger-cat-backgrounds-18.91.0-1.fc19
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2013-05-24 16:24:53 EDT
desktop-backgrounds-19.0.0-2.fc19, schroedinger-cat-backgrounds-18.91.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.