Bug 962967 - Error while compiling libvirt-1.0.5
Error while compiling libvirt-1.0.5
Status: CLOSED DEFERRED
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 16:37 EDT by Javier
Modified: 2016-04-09 19:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-09 19:13:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Javier 2013-05-14 16:37:33 EDT
Description of problem:

Error after invoking 'make' command while compiling libvirt-1.0.5

Version-Release number of selected component (if applicable):

libvirt-1.0.5

How reproducible:

Trying to compile libvirt-1.0.5 from sources.

Steps to Reproduce:

1. Download libvirt-1.0.5 and unpack it
2. Enter in the directory
3. './configure'
4. 'make'
  
Actual results:

 CCLD   libvirt_parthelper
libvirt_parthelper-parthelper.o: In function `main':
/usr/local/src/libvirt-1.0.5/src/storage/parthelper.c:102: undefined reference to `ped_device_get'
/usr/local/src/libvirt-1.0.5/src/storage/parthelper.c:116: undefined reference to `ped_disk_new'
/usr/local/src/libvirt-1.0.5/src/storage/parthelper.c:122: undefined reference to `ped_disk_next_partition'
/usr/local/src/libvirt-1.0.5/src/storage/parthelper.c:174: undefined reference to `ped_disk_next_partition'
collect2: ld returned 1 exit status
make[3]: *** [libvirt_parthelper] Error 1
make[3]: Leaving directory `/usr/local/src/libvirt-1.0.5/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/usr/local/src/libvirt-1.0.5/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/src/libvirt-1.0.5'
make: *** [all] Error 2


Expected results:

Unknown

Additional info:

$ cat /etc/issue
Debian GNU/Linux 6.0 \n \l

$ sudo dpkg -l | grep parted
ii  libparted0-dev                      2.3-5                        The GNU Parted disk partitioning library development files
ii  libparted0debian1                   2.3-5                        The GNU Parted disk partitioning shared library
ii  libparted0debian1-dbg               2.3-5                        The GNU Parted disk partitioning library debug development files
ii  parted                              2.3-5                        The GNU Parted disk partition resizing program
Comment 1 Cole Robinson 2016-04-09 19:13:52 EDT
Sorry this never received a timely response. I suspect this is long since fixed as build issues usually are, but maybe we don't have a correct dep on the right parted version. Closing as DEFERRED, but if anyone can reproduce with modern libvirt please reopen and we can investigate

Note You need to log in before you can comment on or make changes to this bug.