Bug 963020 - reporter-bugzilla crashes if a problem misses the arch element
reporter-bugzilla crashes if a problem misses the arch element
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
abrt_hash:f7a483a85c73c16864f4e085df0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-14 21:47 EDT by Neil
Modified: 2016-11-30 19:44 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-14 11:01:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (16.59 KB, text/plain)
2013-05-14 21:47 EDT, Neil
no flags Details
File: cgroup (140 bytes, text/plain)
2013-05-14 21:47 EDT, Neil
no flags Details
File: core_backtrace (1.11 KB, text/plain)
2013-05-14 21:47 EDT, Neil
no flags Details
File: dso_list (5.25 KB, text/plain)
2013-05-14 21:47 EDT, Neil
no flags Details
File: environ (1.63 KB, text/plain)
2013-05-14 21:47 EDT, Neil
no flags Details
File: limits (1.29 KB, text/plain)
2013-05-14 21:47 EDT, Neil
no flags Details
File: maps (24.95 KB, text/plain)
2013-05-14 21:47 EDT, Neil
no flags Details
File: open_fds (145 bytes, text/plain)
2013-05-14 21:48 EDT, Neil
no flags Details
File: proc_pid_status (938 bytes, text/plain)
2013-05-14 21:48 EDT, Neil
no flags Details

  None (edit)
Description Neil 2013-05-14 21:47:42 EDT
Version-Release number of selected component:
libreport-plugin-bugzilla-2.1.4-5.fc20

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        reporter-bugzilla -b -c /etc/libreport/plugins/bugzilla.conf -F /etc/libreport/plugins/bugzilla_format.conf -A /etc/libreport/plugins/bugzilla_formatdup.conf
crash_function: strlen
executable:     /usr/bin/reporter-bugzilla
kernel:         3.10.0-0.rc1.git2.2.fc20.x86_64
runlevel:       N 5
uid:            1000
var_log_messages: May 14 18:20:17 f19raw abrt[2254]: Saved core dump of pid 2245 (/usr/bin/reporter-bugzilla) to /var/tmp/abrt/ccpp-2013-05-14-18:20:16-2245 (13676544 bytes)

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 strlen at ../sysdeps/x86_64/strlen.S:31
 #1 getString at /usr/src/debug/xmlrpc-c-1.32.5/src/xmlrpc_build.c:35
 #2 getValue at /usr/src/debug/xmlrpc-c-1.32.5/src/xmlrpc_build.c:271
 #3 getStructMember at /usr/src/debug/xmlrpc-c-1.32.5/src/xmlrpc_build.c:148
 #4 getStruct at /usr/src/debug/xmlrpc-c-1.32.5/src/xmlrpc_build.c:172
 #5 getValue at /usr/src/debug/xmlrpc-c-1.32.5/src/xmlrpc_build.c:329
 #6 getArray
 #7 getValue at /usr/src/debug/xmlrpc-c-1.32.5/src/xmlrpc_build.c:321
 #8 xmlrpc_build_value_va at /usr/src/debug/xmlrpc-c-1.32.5/src/xmlrpc_build.c:366
 #9 abrt_xmlrpc_call_full_va at abrt_xmlrpc.c:122
Comment 1 Neil 2013-05-14 21:47:45 EDT
Created attachment 748009 [details]
File: backtrace
Comment 2 Neil 2013-05-14 21:47:47 EDT
Created attachment 748010 [details]
File: cgroup
Comment 3 Neil 2013-05-14 21:47:49 EDT
Created attachment 748011 [details]
File: core_backtrace
Comment 4 Neil 2013-05-14 21:47:51 EDT
Created attachment 748012 [details]
File: dso_list
Comment 5 Neil 2013-05-14 21:47:53 EDT
Created attachment 748013 [details]
File: environ
Comment 6 Neil 2013-05-14 21:47:56 EDT
Created attachment 748014 [details]
File: limits
Comment 7 Neil 2013-05-14 21:47:58 EDT
Created attachment 748015 [details]
File: maps
Comment 8 Neil 2013-05-14 21:48:01 EDT
Created attachment 748016 [details]
File: open_fds
Comment 9 Neil 2013-05-14 21:48:02 EDT
Created attachment 748017 [details]
File: proc_pid_status
Comment 10 Fedora Admin XMLRPC Client 2013-05-20 12:32:52 EDT
The Fedora 20 component was created in error. We only create new Fedora versions when we branch a new release. These bugs are all being moved to rawhide. 

Please retarget them to 19 if they also apply to the Fedora 19 branched release. 

Thanks.
Comment 11 Jakub Filak 2013-06-10 08:26:15 EDT
Fixed in upstream:

commit 3f946c8a4026f8bc94d878cd7b3c409aa2b2d81b
Author: Jakub Filak <jfilak@redhat.com>
Date:   Thu May 23 14:45:00 2013 +0200

    rhbz: don't pass NULL in platform argument
    
    The platform field is not required. Server uses the default value if
    the platform is empty.
    
    From my point of view, it is much better to let user report a bug
    instead of dieing due to a missing file (or worse crashing). Ordinary
    users cannot fix it and will submit the dump dir for emergency analysis.
    
    Closes rhbz#963020
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
    Signed-off-by: Martin Milata <mmilata@redhat.com>

Note You need to log in before you can comment on or make changes to this bug.