Bug 963055 - "vncviewer --AcceptClipboard=0" accepts clipboard updates
"vncviewer --AcceptClipboard=0" accepts clipboard updates
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 00:27 EDT by Matt McCutchen
Modified: 2013-07-27 21:05 EDT (History)
3 users (show)

See Also:
Fixed In Version: tigervnc-1.3.0-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-27 21:05:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix (337 bytes, patch)
2013-05-15 00:34 EDT, Matt McCutchen
no flags Details | Diff

  None (edit)
Description Matt McCutchen 2013-05-15 00:27:45 EDT
Description of problem:
The viewer accepts clipboard updates from the server even when --AcceptClipboard=0 is passed on the command line.

I want to be able to copy and paste between local applications while a VNC session to an untrusted account is running without risk of the VNC session overwriting my local clipboard with harmful content without notice.  To do so, I need to configure the viewer not to accept clipboard updates.  (I have a separate script to copy data between the local and remote clipboards when I request it.)

Version-Release number of selected component (if applicable):
tigervnc-1.2.80-0.10.20130314svn5065.fc18.x86_64

How reproducible:
Always

Steps to Reproduce:
1. vncserver :2 (or some available display number)
2. vncviewer --AcceptClipboard=0 :2
3. In the VNC session, copy something to the clipboard.
4. Go to a window outside the VNC session and paste.

Actual results:
The content from the VNC session is pasted.

Expected results:
The content previously on the local clipboard, if any, is pasted.
Comment 1 Matt McCutchen 2013-05-15 00:34:07 EDT
Created attachment 748055 [details]
Fix

I rebuilt the tigervnc RPMs with the attached patch and it seems to fix the problem.

It looks like the conditional on acceptClipboard was lost in the move to the "new FLTK viewer" (upstream SVN r4345).  Ideally I would take this bug upstream; we'll see if I get around to it.
Comment 2 Pierre Ossman 2013-05-24 06:48:03 EDT
Thanks for spotting this. Will be in the next upstream release. :)
Comment 3 Tim Waugh 2013-07-08 12:35:15 EDT
Should be fixed in tigervnc-1.3.0-1.fc19.
Comment 4 Fedora Update System 2013-07-08 12:38:15 EDT
tigervnc-1.3.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/tigervnc-1.3.0-1.fc19
Comment 5 Fedora Update System 2013-07-24 12:52:04 EDT
tigervnc-1.3.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/tigervnc-1.3.0-3.fc19
Comment 6 Fedora Update System 2013-07-25 20:36:23 EDT
Package tigervnc-1.3.0-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tigervnc-1.3.0-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13650/tigervnc-1.3.0-3.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-07-27 21:05:16 EDT
tigervnc-1.3.0-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.