Bug 963058 - It will fail when you add rhevh-advanced from rhevm3.1
It will fail when you add rhevh-advanced from rhevm3.1
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-hypervisor (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Mike Burns
Pavel Stehlik
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 00:46 EDT by wanghui
Modified: 2016-02-10 15:04 EST (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-28 07:55:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log and screen shot (60.04 KB, application/x-gzip)
2013-05-15 00:46 EDT, wanghui
no flags Details

  None (edit)
Description wanghui 2013-05-15 00:46:30 EDT
Created attachment 748056 [details]
engine log and screen shot

Description of problem:
It will failed when you add rhevh from rhevm3.1

Version-Release number of selected component (if applicable):
rhev-hypervisor-advanced-6.4-20130513.0.el6ev
ovirt-node-2.5.0-17.el6_4.4.noarch
rhevm-3.1.0-53.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Clear install RHEV-H.
2. Configure the network.
3. On the RHEV-M page, input password for adding node through RHEV-M.
4. Add rhevh from rhevm3.1.
  
Actual results:
After step4, it will display install failed on rhevm3.1 page.

Expected results:
After step4, rhevh can be added from rhevm3.1 successfully.

Additional info: 
No this issue in rhevm3.2(rhevm-3.2.0-10.26.rc.el6ev.noarch). It only occurs in rhevm3.1.
Comment 2 wanghui 2013-05-15 03:53:15 EDT
No this issue in normal rhev-hypervisor-6.4.z bulid. It only occurs in rhev-hypervisor-advance-6.4 bulid.
Comment 3 Douglas Schilling Landgraf 2013-05-16 17:38:21 EDT
Hi Mike,

This is caused because vdsm-bootstrap/interface-2/setup cannot identify the platform "RedHatEnterpriseVirtualizationHypervisorAdvanced". 

Currently we support:

"RedHatEnterpriseVirtualizationHypervisor" or "RedHatEnterpriseHypervisor".

We have some options, here 3:

1) Make node report as previous (removing advanced stuff) from /etc/rhev-hypervisor-release

2) Add "RedHatEnterpriseVirtualizationHypervisorAdvanced" to HYPERVISOR_PLATFORMS

3) Change lsb_release() to remove "Advanced"

Alon/Mike, any preference? 

Thanks
Douglas
Comment 4 Mike Burns 2013-05-16 19:36:26 EDT
The problem is you're using your own version of lsb_release.  If you run lsb_release from the command line, you get RedHatEnterpriseVirtualizationHypervisor.  

My understanding is that we can't force an upgrade of RHEV-M/vdsm-bootstrap on any system, so the only option here is to change rhev-hypervisor-release which really shouldn't be changed.
Comment 5 Alon Bar-Lev 2013-05-17 01:49:33 EDT
This is partial dup of bug#948758.

As we have legacy (vdsm-bootstrap) and requirement to be backward compatible.

ovirt-host-deploy does not use lsb release but detect node by:
     os.path.exists('/etc/rhev-hypervisor-release') or
     bool(glob.glob('/etc/ovirt-node-*-release'))

But requires valid distribution to be returned by platform module of python.

I truly don't understand why we play with distribution name.
Comment 6 Douglas Schilling Landgraf 2013-05-17 08:11:42 EDT
(In reply to comment #4)
> The problem is you're using your own version of lsb_release.  If you run
> lsb_release from the command line, you get
> RedHatEnterpriseVirtualizationHypervisor.  
> 
> My understanding is that we can't force an upgrade of RHEV-M/vdsm-bootstrap
> on any system, so the only option here is to change rhev-hypervisor-release
> which really shouldn't be changed.

Make sense Mike, moving back to you.
Comment 8 Mike Burns 2013-05-28 07:55:44 EDT
The issue was only relevant with the new name (rhev-hypervisor-advanced) which was abandoned.  Closing this as notabug
Comment 9 wanghui 2013-05-29 05:21:13 EDT
After reverting rhev-hypervisor-advanced to the old name(rhev-hypervisor), the bug does not exist, and it is fixed indirectly by reverting old name.

Note You need to log in before you can comment on or make changes to this bug.