Bug 963070 - Don't apply V1 -> V2 migration for apps that are already V2
Don't apply V1 -> V2 migration for apps that are already V2
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Morie
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 01:46 EDT by Paul Morie
Modified: 2015-05-14 19:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 23:57:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Morie 2013-05-15 01:46:51 EDT
Don't apply V1 -> V2 migration for apps that are already V2
Comment 1 openshift-github-bot 2013-05-15 04:41:39 EDT
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/9ed1f95fa3cb4c35b8ffda65d8b5dffb1e3b8647
Fix bug 963070

Update migration stepdef to call rhc-admin-migrate
Comment 2 Meng Bo 2013-05-16 05:24:50 EDT
Check this issue on devenv_3232, issue has been fixed. 

V2 app will be skipped during migration.

***time_redeploy_httpd_proxy=0***
***time_restart=0***
***time_total_migrate_gear_measured_from_broker=38918***
Migrating app 'cpl0s0' gear 'a638b654bdfb11e2bf9d12313b0ef6df' with uuid 'a638b654bdfb11e2bf9d12313b0ef6df' on node 'ip-10-100-245-41' for user: chunchen
Migrating gear on node with: /usr/bin/rhc-admin-migrate --login 'chunchen' --migrate-gear 'a638b654bdfb11e2bf9d12313b0ef6df' --app-name 'cpl0s0' --version '2.0.28'
Migrating on node...
***time_migrate_on_node_measured_from_broker=205***
Migrate on node output:
 Skipping V1 -> V2 migration because gear appears to already be V2

Note You need to log in before you can comment on or make changes to this bug.