Bug 963118 - [RHS-C] Failed to invoke scheduled method refreshHooks: java.lang.reflect .InvocationTargetException
[RHS-C] Failed to invoke scheduled method refreshHooks: java.lang.reflect .In...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Sahina Bose
Prasanth
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 03:40 EDT by Prasanth
Modified: 2013-09-23 18:25 EDT (History)
7 users (show)

See Also:
Fixed In Version: bb2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 14740 None None None Never

  None (edit)
Description Prasanth 2013-05-15 03:40:30 EDT
Description of problem: 

Failed to invoke scheduled method refreshHooks: java.lang.reflect
.InvocationTargetException

---------------------------
2013-05-15 00:45:35,939 INFO  [org.ovirt.engine.core.vdsbroker.gluster.GlusterVolumesListVDSCommand] (DefaultQuartzScheduler_Worker-63) START, GlusterVolumesListVDSCommand(HostName = server1
, HostId = d11a630a-d333-494a-92df-f0d80b22982d), log id: 7b55bcb
2013-05-15 00:45:36,053 INFO  [org.ovirt.engine.core.vdsbroker.gluster.GlusterVolumesListVDSCommand] (DefaultQuartzScheduler_Worker-63) FINISH, GlusterVolumesListVDSCommand, return: {a887967
6-64d8-4c99-becd-2da0053781ab=org.ovirt.engine.core.common.businessentities.gluster.GlusterVolumeEntity@c5bca5cf}, log id: 7b55bcb
2013-05-15 00:45:36,732 ERROR [org.ovirt.engine.core.utils.timer.SchedulerUtilQuartzImpl] (DefaultQuartzScheduler_Worker-66) Failed to invoke scheduled method refreshHooks: java.lang.reflect
.InvocationTargetException
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) [rt.jar:1.7.0_19]
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) [rt.jar:1.7.0_19]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_19]
        at java.lang.reflect.Method.invoke(Method.java:601) [rt.jar:1.7.0_19]
        at org.ovirt.engine.core.utils.timer.JobWrapper.execute(JobWrapper.java:60) [scheduler.jar:]
        at org.quartz.core.JobRunShell.run(JobRunShell.java:213) [quartz.jar:]
        at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:557) [quartz.jar:]
Caused by: java.lang.NullPointerException
        at org.ovirt.engine.core.bll.gluster.GlusterHookSyncJob.addOrUpdateHooks(GlusterHookSyncJob.java:94) [bll.jar:]
        at org.ovirt.engine.core.bll.gluster.GlusterHookSyncJob.refreshHooks(GlusterHookSyncJob.java:67) [bll.jar:]
        ... 7 more

2013-05-15 00:45:41,076 INFO  [org.ovirt.engine.core.vdsbroker.gluster.GlusterServersListVDSCommand] (DefaultQuartzScheduler_Worker-69) START, GlusterServersListVDSCommand(HostName = server1
, HostId = d11a630a-d333-494a-92df-f0d80b22982d), log id: 63c927c4
--------------------------------

--------------------------------
2013-05-15 00:52:34,847 INFO  [org.apache.sshd.client.session.ClientSessionImpl] (NioProcessor-7) Session created...
2013-05-15 00:52:34,860 INFO  [org.apache.sshd.client.session.ClientSessionImpl] (NioProcessor-7) Server version string: SSH-2.0-OpenSSH_5.3
2013-05-15 00:52:34,860 INFO  [org.apache.sshd.client.session.ClientSessionImpl] (NioProcessor-7) Received SSH_MSG_KEXINIT
2013-05-15 00:52:34,867 INFO  [org.apache.sshd.client.kex.DHG1] (NioProcessor-7) Send SSH_MSG_KEXDH_INIT
2013-05-15 00:52:34,872 INFO  [org.apache.sshd.client.kex.DHG1] (NioProcessor-7) Received SSH_MSG_KEXDH_REPLY
2013-05-15 00:52:34,879 INFO  [org.apache.sshd.client.session.ClientSessionImpl] (NioProcessor-7) Received SSH_MSG_NEWKEYS
2013-05-15 00:52:34,882 INFO  [org.apache.sshd.client.session.ClientSessionImpl] (NioProcessor-7) Send SSH_MSG_SERVICE_REQUEST for ssh-userauth
2013-05-15 00:52:34,957 INFO  [org.apache.sshd.client.auth.UserAuthPassword] (pool-4-thread-49) Send SSH_MSG_USERAUTH_REQUEST for password
2013-05-15 00:52:34,982 INFO  [org.apache.sshd.client.auth.UserAuthPassword] (NioProcessor-7) Received SSH_MSG_USERAUTH_SUCCESS
2013-05-15 00:52:35,000 INFO  [org.apache.sshd.client.channel.ChannelExec] (pool-4-thread-49) Send SSH_MSG_CHANNEL_OPEN on channel 0
2013-05-15 00:52:35,001 INFO  [org.apache.sshd.client.channel.ChannelExec] (NioProcessor-7) Send SSH_MSG_CHANNEL_REQUEST exec
2013-05-15 00:52:36,861 INFO  [org.quartz.core.JobRunShell] (DefaultQuartzScheduler_Worker-8) Job DEFAULT.org.ovirt.engine.core.bll.gluster.GlusterHookSyncJob.refreshHooks#-9223372036854775773 threw a JobExecutionException: : org.quartz.JobExecutionException: failed to execute job
        at sun.reflect.GeneratedMethodAccessor51.invoke(Unknown Source) [:1.7.0_19]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_19]
        at java.lang.reflect.Method.invoke(Method.java:601) [rt.jar:1.7.0_19]
        at org.ovirt.engine.core.utils.timer.JobWrapper.execute(JobWrapper.java:60) [scheduler.jar:]
        at org.quartz.core.JobRunShell.run(JobRunShell.java:213) [quartz.jar:]
        at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:557) [quartz.jar:]

2013-05-15 00:52:52,889 INFO  [org.apache.sshd.client.channel.ChannelExec] (NioProcessor-7) Received SSH_MSG_CHANNEL_REQUEST on channel 0
2013-05-15 00:52:52,929 INFO  [org.apache.sshd.client.session.ClientSessionImpl] (NioProcessor-7) Session root@qa-vm08.lab.eng.blr.redhat.com/10.70.36.80:22 closed
2013-05-15 00:52:57,337 INFO  [org.quartz.core.JobRunShell] (DefaultQuartzScheduler_Worker-25) Job DEFAULT.org.ovirt.engine.core.bll.gluster.GlusterHookSyncJob.refreshHooks#-9223372036854775773 threw a JobExecutionException: : org.quartz.JobExecutionException: failed to execute job
        at sun.reflect.GeneratedMethodAccessor51.invoke(Unknown Source) [:1.7.0_19]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_19]
        at java.lang.reflect.Method.invoke(Method.java:601) [rt.jar:1.7.0_19]
        at org.ovirt.engine.core.utils.timer.JobWrapper.execute(JobWrapper.java:60) [scheduler.jar:]
        at org.quartz.core.JobRunShell.run(JobRunShell.java:213) [quartz.jar:]
        at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:557) [quartz.jar:]
--------------------------------

Version-Release number of selected component (if applicable):  Red Hat Storage Console Version: 2.1.0-0.bb1.el6rhs 


How reproducible: Always


Steps to Reproduce:
1. Create a new cluster
2. Add a server to it
3. Make sure that the "Default" cluster is empty
4. Manually add some hooks to this server from the backend 
  
Actual results: Hooks available in the backend server is not getting synced in the UI 


Expected results: Hooks available in the backend server should get synced in the UI 


Additional info: This happens only when there is an empty cluster present. If we directly add a server to the "Default" cluster and does not create any empty cluster, this issue is not seen.
Comment 2 Prasanth 2013-06-07 07:08:42 EDT
Verified as fixed in bb2
Comment 3 Scott Haines 2013-09-23 18:25:41 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.