Bug 963157 - met script error when moving a gear to another node
met script error when moving a gear to another node
Status: CLOSED DUPLICATE of bug 963156
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
All All
high Severity high
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 05:37 EDT by zhaozhanqi
Modified: 2015-05-14 22:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-15 06:37:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhaozhanqi 2013-05-15 05:37:17 EDT
Description of problem:
met script error when moving a gear to another node

Version-Release number of selected component (if applicable):
devenv_3227

How reproducible:
always

Steps to Reproduce:
1. setup a multi-node env (a, b)
2. create a district add node 'a' and 'b' to this district
3. create one app 
4. move the app to another node
  
Actual results:

[root@ip-10-62-23-236 ~]# oo-admin-move --gear_uuid 165155074000759201726464 -i ip-10-83-87-100
URL: http://jbosstest-zqd.dev.rhcloud.com
Login: zzhao@redhat.com
App UUID: 5193382b468a8587cb000122
Gear UUID: 5193382b468a8587cb000122
DEBUG: Source district uuid: 51933513468a8511f2000001
DEBUG: Destination district uuid: 51933513468a8511f2000001
DEBUG: Getting existing app 'jbosstest' status before moving
DEBUG: Error performing status on existing app on try 1: undefined method `[]' for nil:NilClass
DEBUG: Error performing status on existing app on try 2: undefined method `[]' for nil:NilClass
/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.9.1/lib/openshift/mcollective_application_container_proxy.rb:2094:in `block in get_cart_status': undefined method `[]' for nil:NilClass (NoMethodError)
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.9.1/lib/openshift/mcollective_application_container_proxy.rb:2238:in `block in do_with_retry'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.9.1/lib/openshift/mcollective_application_container_proxy.rb:2236:in `each'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.9.1/lib/openshift/mcollective_application_container_proxy.rb:2236:in `do_with_retry'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.9.1/lib/openshift/mcollective_application_container_proxy.rb:2092:in `get_cart_status'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.9.1/lib/openshift/mcollective_application_container_proxy.rb:2068:in `get_app_status'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.9.1/lib/openshift/mcollective_application_container_proxy.rb:1794:in `move_gear'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.9.1/lib/openshift/mcollective_application_container_proxy.rb:1766:in `block in move_gear_secure'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-controller-1.9.1/app/models/application.rb:1258:in `run_in_application_lock'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.9.1/lib/openshift/mcollective_application_container_proxy.rb:1765:in `move_gear_secure'
	from /usr/sbin/oo-admin-move:112:in `<main>'


Expected results:
can move successfully

Additional info:
Comment 1 Xiaoli Tian 2013-05-15 06:37:46 EDT

*** This bug has been marked as a duplicate of bug 963156 ***

Note You need to log in before you can comment on or make changes to this bug.