Bug 963240 - SELinux is preventing /usr/sbin/abrt-dbus from 'open' accesses on the file /var/tmp/abrt/ccpp-2013-05-15-14:01:28-1718/reported_to.
SELinux is preventing /usr/sbin/abrt-dbus from 'open' accesses on the file /v...
Status: CLOSED DUPLICATE of bug 963239
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:b2f8eb26f8bb8e8c0c4550ca094...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 09:17 EDT by JayMac
Modified: 2013-05-15 09:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-15 09:28:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JayMac 2013-05-15 09:17:09 EDT
Description of problem:
SELinux is preventing /usr/sbin/abrt-dbus from 'open' accesses on the file /var/tmp/abrt/ccpp-2013-05-15-14:01:28-1718/reported_to.

*****  Plugin restorecon (99.5 confidence) suggests  *************************

If you want to fix the label. 
/var/tmp/abrt/ccpp-2013-05-15-14:01:28-1718/reported_to default label should be abrt_var_cache_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /var/tmp/abrt/ccpp-2013-05-15-14:01:28-1718/reported_to

*****  Plugin catchall (1.49 confidence) suggests  ***************************

If you believe that abrt-dbus should be allowed open access on the reported_to file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep abrt-dbus /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:initrc_tmp_t:s0
Target Objects                /var/tmp/abrt/ccpp-2013-05-15-14:01:28-1718/report
                              ed_to [ file ]
Source                        abrt-dbus
Source Path                   /usr/sbin/abrt-dbus
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-dbus-2.1.2-2.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-92.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.8.11-200.fc18.x86_64 #1 SMP Wed
                              May 1 19:44:27 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-15 14:04:30 BST
Last Seen                     2013-05-15 14:04:30 BST
Local ID                      b07de26f-4597-4b13-bafa-55aa402aa0f7

Raw Audit Messages
type=AVC msg=audit(1368623070.730:404): avc:  denied  { open } for  pid=16130 comm="abrt-dbus" path="/var/tmp/abrt/ccpp-2013-05-15-14:01:28-1718/reported_to" dev="dm-2" ino=2623799 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:initrc_tmp_t:s0 tclass=file


type=SYSCALL msg=audit(1368623070.730:404): arch=x86_64 syscall=open success=yes exit=ENXIO a0=12bac80 a1=20000 a2=12bac80 a3=b items=0 ppid=1 pid=16130 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=abrt-dbus exe=/usr/sbin/abrt-dbus subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)

Hash: abrt-dbus,abrt_t,initrc_tmp_t,file,open

audit2allow

#============= abrt_t ==============
allow abrt_t initrc_tmp_t:file open;

audit2allow -R
require {
	type abrt_t;
}

#============= abrt_t ==============
init_read_script_tmp_files(abrt_t)


Additional info:
hashmarkername: setroubleshoot
kernel:         3.8.11-200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-05-15 09:28:53 EDT

*** This bug has been marked as a duplicate of bug 963239 ***

Note You need to log in before you can comment on or make changes to this bug.