Bug 963272 - Relay party error preventing logging in to katello nightly in free IPA configuration
Relay party error preventing logging in to katello nightly in free IPA config...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Marek Hulan
Katello QA List
: Triaged
Depends On: 962249
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 10:28 EDT by sthirugn@redhat.com
Modified: 2013-07-18 17:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:24:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Relay party consult error during log in (48.14 KB, image/png)
2013-05-15 10:28 EDT, sthirugn@redhat.com
no flags Details

  None (edit)
Description sthirugn@redhat.com 2013-05-15 10:28:45 EDT
Created attachment 748330 [details]
Relay party consult error during log in

Description of problem:
Relay party error preventing logging in to katello nightly in free IPA configuration

Version-Release number of selected component (if applicable):
* candlepin-0.8.7-1.el6.noarch
* candlepin-selinux-0.8.7-1.el6.noarch
* candlepin-tomcat6-0.8.7-1.el6.noarch
* elasticsearch-0.19.9-7.el6.noarch
* katello-1.4.2-1.git.333.d2a35bc.el6.noarch
* katello-all-1.4.2-1.git.333.d2a35bc.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-1.el6.noarch
* katello-cli-1.4.2-1.git.48.441089b.el6.noarch
* katello-cli-common-1.4.2-1.git.48.441089b.el6.noarch
* katello-common-1.4.2-1.git.333.d2a35bc.el6.noarch
* katello-configure-1.4.3-1.git.12.bc3684c.el6.noarch
* katello-glue-candlepin-1.4.2-1.git.333.d2a35bc.el6.noarch
* katello-glue-elasticsearch-1.4.2-1.git.333.d2a35bc.el6.noarch
* katello-glue-pulp-1.4.2-1.git.333.d2a35bc.el6.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-repos-1.4.2-1.el6.noarch
* katello-selinux-1.4.3-1.git.3.ce8227b.el6.noarch
* pulp-rpm-plugins-2.1.1-0.10.beta.el6.noarch
* pulp-selinux-2.1.1-0.10.beta.el6.noarch
* pulp-server-2.1.1-0.10.beta.el6.noarch


How reproducible:
Always

Steps to Reproduce:
1. Install katello nightly
2. Use free IPA configuration in katello-configure
katello-configure --user-name=$user --user-email=$email --ldap-server=$server --auth-method=ldap --ldap-port=389 --ldap-server-type='free_ipa' --ldap-users-basedn=$usersbasedn --ldap-group-basedn=$groupsbasedn --ldap-roles=true --ldap-anon-queries=false --ldap-service-user=$serviceuser --ldap-service-pass='$servicepass --ldap-encryption=start_tls
3. Log in to Web UI with the correct free ipa user credentials
  
Actual results:
Relay party error occured

Expected results:
User is logged in successfully

Additional info:
This bug is related to https://bugzilla.redhat.com/show_bug.cgi?id=962249
Comment 1 sthirugn@redhat.com 2013-05-15 10:32:28 EDT
FWIW, the same build works fine with Active directory configuration
Comment 2 Marek Hulan 2013-05-15 10:42:28 EDT
You are using old katello-installer, this should be already fixed in d057e97e74e6b6aedffc717985601dd3827616b7. Could you please retry with latest nightlies?
Comment 3 sthirugn@redhat.com 2013-05-15 12:40:22 EDT
I was able to log in successfully but getting an error in home page which prevents further navigation.  A new Bug is created to track this issue: https://bugzilla.redhat.com/show_bug.cgi?id=963329

Software Version:
* candlepin-0.8.7-1.el6.noarch
* candlepin-selinux-0.8.7-1.el6.noarch
* candlepin-tomcat6-0.8.7-1.el6.noarch
* elasticsearch-0.19.9-7.el6.noarch
* katello-1.4.2-1.git.333.d2a35bc.el6.noarch
* katello-all-1.4.2-1.git.333.d2a35bc.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-1.el6.noarch
* katello-cli-1.4.2-1.git.48.441089b.el6.noarch
* katello-cli-common-1.4.2-1.git.48.441089b.el6.noarch
* katello-common-1.4.2-1.git.333.d2a35bc.el6.noarch
* katello-configure-1.4.3-1.git.17.b0067d4.el6.noarch
* katello-glue-candlepin-1.4.2-1.git.333.d2a35bc.el6.noarch
* katello-glue-elasticsearch-1.4.2-1.git.333.d2a35bc.el6.noarch
* katello-glue-pulp-1.4.2-1.git.333.d2a35bc.el6.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-repos-1.4.2-1.el6.noarch
* katello-selinux-1.4.3-1.git.3.ce8227b.el6.noarch
* pulp-rpm-plugins-2.1.1-0.10.beta.el6.noarch
* pulp-selinux-2.1.1-0.10.beta.el6.noarch
* pulp-server-2.1.1-0.10.beta.el6.noarch
Comment 4 Mike McCune 2013-07-18 17:24:02 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.