Bug 963282 - [oo-accept-node] httpd config references DNS name without associated gear
[oo-accept-node] httpd config references DNS name without associated gear
Status: CLOSED UPSTREAM
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
1.x
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Rob Millner
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 10:54 EDT by Kenny Woodson
Modified: 2013-11-17 19:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-17 14:34:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kenny Woodson 2013-05-15 10:54:54 EDT
Description of problem:

When cleaning up after the recent release and changes to accept-node we have been seeing these errors:

FAIL: httpd config references DNS name without associated gear: 'pfpcore-apsp001.rhcloud.com'

At some point in time in the past the namespace has changed and left behind this artifact.  The new url is pfpcore-hampton.rhcloud.com.  

When namespaces change we need to ensure that we are cleaning up the old urls.

I have seen at least 10-15 of these exact errors.

Version-Release number of selected component (if applicable):

2.0.27 just went out the door.

How reproducible:

I'm not sure as most of the creation dates for these are back in march but its definitely worth trying to reproduce.

Steps to Reproduce:
1. Create an application under a certain namespace.
2. Change the namespace of the account.
3. Verify the config was properly removed from the frontend apache.  Can do this by running oo-accept-node -v and see if you see the error.
  
Actual results:

Artifacts left behind.

Expected results:

Remove the old artifacts and swap the new namespace into the frontend apache.

Additional info:

These are extremely painful and require manual cleanup.
Comment 1 Rob Millner 2013-05-16 20:05:33 EDT
It looks as though we are no longer supporting namespace changes to domains which contain applications.

# rhc domain update rmillner0100 0010renllimr
Changing namespace 'rmillner0100' to '0010renllimr' ... Domain contains applications. Delete applications first before changing the domain namespace.


And the code to do namespace updates was removed from the FrontendHttpServer class in the previous release (2.0.27).


The rhc-fix-stale-frontend script should help and can take multiple names on the command line.
Comment 2 Rob Millner 2013-05-16 20:07:08 EDT
What's the contents of .env for the gear in question?  I'm concerned this is another instance of an app which has ancient variable names.
Comment 3 Kenny Woodson 2013-05-17 13:20:17 EDT
This application no longer exists.  I see logs on two ex-lg-node(7 & 9) servers but no remains of this application.

If this is not allowed any more than I suggest we move this to closed.
Comment 4 Rob Millner 2013-05-17 14:34:10 EDT
Agreed - upstream can no longer express this bug since the feature has been removed.

Note You need to log in before you can comment on or make changes to this bug.