Bug 963284 - pcre_dfa_exec() crashes on workspace handling by JIT
pcre_dfa_exec() crashes on workspace handling by JIT
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pcre (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
https://lists.exim.org/lurker/message...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 11:00 EDT by Petr Pisar
Modified: 2013-08-30 02:09 EDT (History)
3 users (show)

See Also:
Fixed In Version: pcre-8.33-0.3.RC1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-30 02:09:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reproducer (754 bytes, text/plain)
2013-05-15 11:00 EDT, Petr Pisar
no flags Details

  None (edit)
Description Petr Pisar 2013-05-15 11:00:24 EDT
Created attachment 748362 [details]
Reproducer

Attached code crashes with pcre-8.33-0.2.RC1.fc20.x86_64. Reported to upstream <https://lists.exim.org/lurker/message/20130514.163003.d8983c39.en.html>, possible fix has been posted there.
Comment 1 Petr Pisar 2013-05-16 02:38:14 EDT
Simpler reproducer using pcretest:

# pcretest 
PCRE version 8.33-RC1 2013-04-28

  re> /abcd/
data> abcd\O0\D
Neoprávněný přístup do paměti (SIGSEGV)

Fixed by upstream commit:

commit f4176cfb682170c5e9246949df653c82200d7259
Author: ph10 <ph10@2f5784b3-3f2a-0410-8824-cb99058d5e15>
Date:   Wed May 15 16:53:18 2013 +0000

    Fix segfault when pcre_dfa_exec() is called with an output vector of length
    less than 2.
    
    
    git-svn-id: svn://vcs.exim.org/pcre/code/trunk@1334 2f5784b3-3f2a-0410-8824-cb99058d5e15
Comment 2 Petr Pisar 2013-05-16 07:14:34 EDT
pcre has been broken since 8.32. Fedoras ≥ 19 are affected.
Comment 3 Fedora Update System 2013-05-16 07:56:12 EDT
pcre-8.32-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/pcre-8.32-6.fc19
Comment 4 Fedora Update System 2013-05-24 16:51:53 EDT
pcre-8.32-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.