Bug 963286 - Rip out remaining references to .uservars directory in V2 code
Rip out remaining references to .uservars directory in V2 code
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Paul Morie
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 11:01 EDT by Paul Morie
Modified: 2015-05-14 19:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-10 23:58:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Morie 2013-05-15 11:01:14 EDT
Rip out remaining references to .uservars directory in V2 code
Comment 1 Paul Morie 2013-05-15 13:47:03 EDT
Must remove set_uservars_env in bash sdk
Comment 2 Paul Morie 2013-05-16 21:47:57 EDT
PR submitted
Comment 3 Paul Morie 2013-05-16 21:48:20 EDT
PR submitted
Comment 4 openshift-github-bot 2013-05-16 23:47:47 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/b65d94dc5cb557975776d1c19a59c088d98e63b8
Fix bug 963286: remove uservars from v2
Comment 5 Paul Morie 2013-05-17 01:34:45 EDT
QE-

The net result of this change is that while you will still see a uservars directory in V2 apps, there should not be any entries in this directory.  The directory is still created because the creation is necessary for V1 and on a shared code path, but in practice V2 apps should not use this directory, and the V1 -> V2 migration should clear this directory.
Comment 6 Jianwei Hou 2013-05-20 04:39:00 EDT
Verified on devenv_3247 migration

The .env/.uservars directory with contents under it are removed. The env vars are realocated under .env directory

[as2s-jhou.dev.rhcloud.com 5199968fdb86250a92000005]\> tree .env/
.env/
├── CARTRIDGE_VERSION_2
├── HISTFILE
├── HOME
├── JENKINS_PASSWORD
├── JENKINS_URL
├── JENKINS_USERNAME
├── mongodb
│   ├── OPENSHIFT_MONGODB_DB_GEAR_DNS
│   ├── OPENSHIFT_MONGODB_DB_GEAR_UUID
│   ├── OPENSHIFT_MONGODB_DB_HOST
│   ├── OPENSHIFT_MONGODB_DB_PASSWORD
│   ├── OPENSHIFT_MONGODB_DB_PORT
│   ├── OPENSHIFT_MONGODB_DB_URL
│   └── OPENSHIFT_MONGODB_DB_USERNAME
├── mysql
│   ├── OPENSHIFT_MYSQL_DB_GEAR_DNS
│   ├── OPENSHIFT_MYSQL_DB_GEAR_UUID
│   ├── OPENSHIFT_MYSQL_DB_HOST
│   ├── OPENSHIFT_MYSQL_DB_PASSWORD
│   ├── OPENSHIFT_MYSQL_DB_PORT
│   ├── OPENSHIFT_MYSQL_DB_URL
│   └── OPENSHIFT_MYSQL_DB_USERNAME
├── OPENSHIFT_APP_DNS
├── OPENSHIFT_APP_NAME
├── OPENSHIFT_APP_SSH_KEY
├── OPENSHIFT_APP_SSH_PUBLIC_KEY
├── OPENSHIFT_APP_UUID
├── OPENSHIFT_DATA_DIR
├── OPENSHIFT_GEAR_DNS
├── OPENSHIFT_GEAR_NAME
├── OPENSHIFT_GEAR_UUID
├── OPENSHIFT_HAPROXY_IP
├── OPENSHIFT_HAPROXY_PORT
├── OPENSHIFT_HAPROXY_STATUS_IP
├── OPENSHIFT_HAPROXY_STATUS_PORT
├── OPENSHIFT_HOMEDIR
├── OPENSHIFT_INTERNAL_IP
├── OPENSHIFT_INTERNAL_PORT
├── OPENSHIFT_JBOSSAS_CLUSTER_PORT
├── OPENSHIFT_JBOSSAS_CLUSTER_PROXY_PORT
├── OPENSHIFT_JBOSSAS_HTTP_IP
├── OPENSHIFT_JBOSSAS_HTTP_PORT
├── OPENSHIFT_JBOSSAS_IP
├── OPENSHIFT_JBOSSAS_MESSAGING_PORT
├── OPENSHIFT_JBOSSAS_MESSAGING_PROXY_PORT
├── OPENSHIFT_JBOSSAS_MESSAGING_THROUGHPUT_PORT
├── OPENSHIFT_JBOSSAS_MESSAGING_THROUGHPUT_PROXY_PORT
├── OPENSHIFT_JBOSSAS_PORT
├── OPENSHIFT_JBOSSAS_PROXY_PORT
├── OPENSHIFT_JBOSSAS_REMOTING
├── OPENSHIFT_JBOSSAS_REMOTING_PORT
├── OPENSHIFT_JBOSSAS_REMOTING_PROXY_PORT
├── OPENSHIFT_NAMESPACE
├── OPENSHIFT_PRIMARY_CARTRIDGE_DIR
├── OPENSHIFT_REPO_DIR
├── OPENSHIFT_TMP_DIR
├── postgresql
│   ├── OPENSHIFT_POSTGRESQL_DB_GEAR_DNS
│   ├── OPENSHIFT_POSTGRESQL_DB_GEAR_UUID
│   ├── OPENSHIFT_POSTGRESQL_DB_HOST
│   ├── OPENSHIFT_POSTGRESQL_DB_PASSWORD
│   ├── OPENSHIFT_POSTGRESQL_DB_PORT
│   ├── OPENSHIFT_POSTGRESQL_DB_URL
│   └── OPENSHIFT_POSTGRESQL_DB_USERNAME
├── TMP
├── TMPDIR
└── TMP_DIR

Note You need to log in before you can comment on or make changes to this bug.