Bug 963290 - [abrt] setroubleshoot-server-3.2.3-3.fc18: __init__.py:22:swig_import_helper:ImportError: /usr/lib/python2.7/site-packages/selinux/_selinux.so: undefined symbol: selinux_binary_policy_path_min_max
[abrt] setroubleshoot-server-3.2.3-3.fc18: __init__.py:22:swig_import_helper:...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
abrt_hash:a3a90a839a47cb4934de7663d00...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 11:07 EDT by Munawar Ahmed
Modified: 2013-05-15 11:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-15 11:34:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (959 bytes, text/plain)
2013-05-15 11:07 EDT, Munawar Ahmed
no flags Details
File: core_backtrace (304 bytes, text/plain)
2013-05-15 11:07 EDT, Munawar Ahmed
no flags Details
File: environ (1.46 KB, text/plain)
2013-05-15 11:07 EDT, Munawar Ahmed
no flags Details

  None (edit)
Description Munawar Ahmed 2013-05-15 11:07:03 EDT
Description of problem:
Dont know!

Version-Release number of selected component:
setroubleshoot-server-3.2.3-3.fc18

Additional info:
cmdline:        /usr/bin/python -Es /usr/bin/sealert -b
dso_list:       libselinux-python-2.1.12-7.3.fc18.i686
executable:     /usr/bin/sealert
kernel:         3.8.11-200.fc18.i686
uid:            1000
ureports_counter: 1

Truncated backtrace:
__init__.py:22:swig_import_helper:ImportError: /usr/lib/python2.7/site-packages/selinux/_selinux.so: undefined symbol: selinux_binary_policy_path_min_max

Traceback (most recent call last):
  File "/usr/bin/sealert", line 36, in <module>
    import selinux
  File "/usr/lib/python2.7/site-packages/selinux/__init__.py", line 26, in <module>
    _selinux = swig_import_helper()
  File "/usr/lib/python2.7/site-packages/selinux/__init__.py", line 22, in swig_import_helper
    _mod = imp.load_module('_selinux', fp, pathname, description)
ImportError: /usr/lib/python2.7/site-packages/selinux/_selinux.so: undefined symbol: selinux_binary_policy_path_min_max

Local variables in innermost frame:
fp: <closed file '/usr/lib/python2.7/site-packages/selinux/_selinux.so', mode 'rb' at 0x84abac8>
imp: <module 'imp' (built-in)>
dirname: <function dirname at 0xb74b7b1c>
pathname: '/usr/lib/python2.7/site-packages/selinux/_selinux.so'
description: ('.so', 'rb', 3)
Comment 1 Munawar Ahmed 2013-05-15 11:07:07 EDT
Created attachment 748365 [details]
File: backtrace
Comment 2 Munawar Ahmed 2013-05-15 11:07:11 EDT
Created attachment 748366 [details]
File: core_backtrace
Comment 3 Munawar Ahmed 2013-05-15 11:07:17 EDT
Created attachment 748367 [details]
File: environ
Comment 4 Daniel Walsh 2013-05-15 11:34:05 EDT
This looks like you have a partially updated system.  Could you complete the update and see if this problems disappears.

Note You need to log in before you can comment on or make changes to this bug.