Bug 963333 - tests/basic/rpm.t leaves /var/tmp/rpm-tests.* directories when there are no changes requiring this test
tests/basic/rpm.t leaves /var/tmp/rpm-tests.* directories when there are no c...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: build (Show other bugs)
mainline
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Kaleb KEITHLEY
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 12:53 EDT by Kaleb KEITHLEY
Modified: 2015-12-01 11:45 EST (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:21:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2013-05-15 12:53:59 EDT
Description of problem:

empty /var/tmp/rpm-tests.* directories are left behind.


Version-Release number of selected component (if applicable):

All

How reproducible:

run a regression test that doesn't change certain files

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2013-05-15 13:05:03 EDT
REVIEW: http://review.gluster.org/5015 (tests: basic/rpm.t leaves /var/tmp/rpm-tests.* directories) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 2 Anand Avati 2013-05-15 20:30:52 EDT
COMMIT: http://review.gluster.org/5015 committed in master by Anand Avati (avati@redhat.com) 
------
commit 6612f4d74792016add6d9067f732bad999d13b80
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Wed May 15 13:02:23 2013 -0400

    tests: basic/rpm.t leaves /var/tmp/rpm-tests.* directories
    
    When the test is terminated early because nothing changed that requires
    this test, the /var/tmp/rpm-tests.xxxxxx is not removed.
    
    BUG: 963333
    Change-Id: I98d44ca34f14d62da9d836c41a9015cfb520ff96
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/5015
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>

Note You need to log in before you can comment on or make changes to this bug.