This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 963414 - Install of httpd/mod_ssl fails for FC18
Install of httpd/mod_ssl fails for FC18
Status: CLOSED WORKSFORME
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ivan Chavero
Ami Jeain
: Triaged
Depends On:
Blocks: 963423
  Show dependency treegraph
 
Reported: 2013-05-15 14:34 EDT by Robert Harker
Modified: 2015-06-04 17:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 20:59:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Errors and logs from failed packstack command (15.32 KB, application/octet-stream)
2013-05-15 14:34 EDT, Robert Harker
no flags Details
packstack-answers (7.59 KB, application/octet-stream)
2013-05-15 14:46 EDT, Robert Harker
no flags Details

  None (edit)
Description Robert Harker 2013-05-15 14:34:01 EDT
Created attachment 748430 [details]
Errors and logs from failed packstack command

Description of problem:
On a fresh minimal install of FC18 packstack fails with:
ERROR : Error during puppet run : err: /Stage[main]/Apache/Service[httpd]/ensure: c
hange from stopped to running failed: Could not start Service[httpd]: Execution of 
'/sbin/service httpd start' returned 1:  at /var/tmp/packstack/693228f524c949d4a589
dd43d1318a02/modules/apache/manifests/init.pp:36
Please check log file /var/tmp/packstack/20130514-230311-XCBzoF/openstack-setup.log
 for more information


Version-Release number of selected component (if applicable):
openstack-packstack.noarch           2013.1.1-0.4.dev538.fc19 @openstack-grizzly
mod_ssl.x86_64                       1:2.4.4-2.fc18           @updates          
httpd.x86_64                         2.4.4-2.fc18             @updates          

How reproducible:
4 times after 4 fresh installs

Steps to Reproduce:
1. Install a minimal install of FC18
2. install openstack-packstack
3. run packstack
   I have been using packstack --answer-file=packstack-answers
  
Actual results:
ERROR : Error during puppet run : err: /Stage[main]/Apache/Service[httpd]/ensure: c
hange from stopped to running failed: Could not start Service[httpd]: Execution of 
'/sbin/service httpd start' returned 1:  at /var/tmp/packstack/693228f524c949d4a589
dd43d1318a02/modules/apache/manifests/init.pp:36
Please check log file /var/tmp/packstack/20130514-230311-XCBzoF/openstack-setup.log
 for more information

Expected results:
Successful install of packstack

Additional info:
The problem is with the /etc/httpd/conf.d/ssl.conf file.
The SSLSessionCache uses shmcb which is not supported.
A workaround is commenting out these two lines:
#SSLSessionCache         shmcb:/run/httpd/sslcache(512000)
#SSLSessionCacheTimeout  300
Comment 1 Robert Harker 2013-05-15 14:46:46 EDT
Created attachment 748447 [details]
packstack-answers

Note You need to log in before you can comment on or make changes to this bug.