Bug 963430 - SyntaxError: not well-formed (invalid token): line 1, column 0
SyntaxError: not well-formed (invalid token): line 1, column 0
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.4
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
abrt_hash:81b5c1b5a24637aad736248b12e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 15:22 EDT by Og Maciel
Modified: 2014-02-25 15:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 15:09:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: release (24 bytes, text/plain)
2013-05-15 15:22 EDT, Og Maciel
no flags Details
File: version (3 bytes, text/plain)
2013-05-15 15:22 EDT, Og Maciel
no flags Details
File: hashmarkername (8 bytes, text/plain)
2013-05-15 15:22 EDT, Og Maciel
no flags Details
File: type (9 bytes, text/plain)
2013-05-15 15:22 EDT, Og Maciel
no flags Details
File: exnFileName (23 bytes, text/plain)
2013-05-15 15:22 EDT, Og Maciel
no flags Details
File: product (24 bytes, text/plain)
2013-05-15 15:22 EDT, Og Maciel
no flags Details
File: environ (1016 bytes, text/plain)
2013-05-15 15:22 EDT, Og Maciel
no flags Details

  None (edit)
Description Og Maciel 2013-05-15 15:22:19 EDT
Version-Release number of selected component:
anaconda-13.21.195

Additional info:
libreport version: 2.0.9
cmdline:        /usr/bin/python  /usr/bin/anaconda
kernel:         2.6.32-358.el6.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 13.21.195 exception report
:Traceback (most recent call first):
:  File "<string>", line 64, in __iter__
:  File "/usr/lib/yum-plugins/whiteout.py", line 46, in postreposetup_hook
:    for event, elem in iterparse(infile):
:  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 184, in run
:    func(conduitcls(self, self.base, conf, **kwargs))
:  File "/usr/lib/python2.6/site-packages/yum/repos.py", line 105, in doSetup
:    self.ayum.plugins.run('postreposetup')
:  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 620, in _getRepos
:    self._repos.doSetup(thisrepo)
:  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 587, in doRepoSetup
:    return self._getRepos(thisrepo, True)
:  File "/usr/lib/anaconda/yuminstall.py", line 1390, in <lambda>
:    self.__withFuncDo(anaconda, lambda r: self.ayum.doRepoSetup(thisrepo=r.id),
:  File "/usr/lib/anaconda/yuminstall.py", line 1420, in __withFuncDo
:    fn(repo)
:  File "/usr/lib/anaconda/yuminstall.py", line 1392, in doRepoSetup
:    callback=RepoSetupPulseProgress(anaconda.intf))
:  File "/usr/lib/anaconda/yuminstall.py", line 1350, in doBackendSetup
:    self.doRepoSetup(anaconda)
:  File "/usr/lib/anaconda/backend.py", line 225, in doBackendSetup
:    if anaconda.backend.doBackendSetup(anaconda) == DISPATCH_BACK:
:  File "/usr/lib/anaconda/dispatch.py", line 210, in moveStep
:    rc = stepFunc(self.anaconda)
:  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
:    self.moveStep()
:  File "/usr/lib/anaconda/dispatch.py", line 233, in currentStep
:    self.gotoNext()
:  File "/usr/lib/anaconda/text.py", line 602, in run
:    (step, instance) = anaconda.dispatch.currentStep()
:  File "/usr/bin/anaconda", line 1132, in <module>
:    anaconda.intf.run(anaconda)
:SyntaxError: not well-formed (invalid token): line 1, column 0
Comment 1 Og Maciel 2013-05-15 15:22:22 EDT
Created attachment 748465 [details]
File: release
Comment 2 Og Maciel 2013-05-15 15:22:23 EDT
Created attachment 748466 [details]
File: version
Comment 3 Og Maciel 2013-05-15 15:22:25 EDT
Created attachment 748467 [details]
File: hashmarkername
Comment 4 Og Maciel 2013-05-15 15:22:26 EDT
Created attachment 748468 [details]
File: type
Comment 5 Og Maciel 2013-05-15 15:22:28 EDT
Created attachment 748469 [details]
File: exnFileName
Comment 6 Og Maciel 2013-05-15 15:22:30 EDT
Created attachment 748470 [details]
File: product
Comment 7 Og Maciel 2013-05-15 15:22:31 EDT
Created attachment 748471 [details]
File: environ
Comment 10 Samantha N. Bueno 2013-07-01 15:21:06 EDT
"During the initial setup I came across the traceback included here."

What exactly do you mean? At what point during installation did this traceback occur?

Also, thanks for attaching some logs, but you attached the wrong ones. When a traceback occurs, a file gets generated in /tmp, of the format /tmp/anaconda-tb-* (* is some random characters). Please attach that to the report.
Comment 11 Joshua Kugler 2013-08-01 21:31:18 EDT
I have no idea if this is your problem, but I was fiddling with one of my repos, and accidentally created a comps.xml file that ended up being comps.xml.gz.gz. Yes, compressed twice. Once I fixed that, the instal when fine!
Comment 12 RHEL Product and Program Management 2013-10-13 23:33:44 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 13 Chris Lumens 2014-02-25 15:09:46 EST
This is almost certainly due to malformed repo metadata.  Please double check that no problems occurred when generating your installation tree.

Note You need to log in before you can comment on or make changes to this bug.