Bug 963439 - drupal-quickstart: error while installing drush
drupal-quickstart: error while installing drush
Status: CLOSED WORKSFORME
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Vojtech Vitek
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 15:44 EDT by Thomas Bétrancourt
Modified: 2015-05-14 19:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-28 13:29:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Bétrancourt 2013-05-15 15:44:33 EDT
Description of problem:
Error while deploying the application when openshift tries to install drush

Version-Release number of selected component (if applicable):
git://github.com/openshift/drupal-quickstart.git (commit e755b504c78766f46e223bdb6bc33a0e865d104a) 

How reproducible:
always

Steps to Reproduce:
1. rhc app create drupal01 php
2. rhc cartridge add mysql -a drupal01
3. cd drupal01 && git remote add upstream git://github.com/openshift/drupal-quickstart.git
4. git pull -s recursive -X theirs upstream master
5. git push
  
Actual results:
remote: restart_on_add=false
remote: Waiting for stop to finish
remote: Done
remote: restart_on_add=false
remote: Running .openshift/action_hooks/pre_build
remote: Checking pear: pear.drush.org/drush
remote: 
remote: Attempting to discover channel "pear.drush.org"...
remote: Attempting fallback to https instead of http on channel "pear.drush.org"...
remote: unknown channel "pear.drush.org" in "pear.drush.org/drush"
remote: invalid package name/package file "pear.drush.org/drush"
remote: install failed
remote: Running .openshift/action_hooks/build
remote: ERROR: The 'php' directory in your Git repo prevents Drupal from being installed.  Please remove 'php' and push again.
remote: Running .openshift/action_hooks/deploy
remote: No sites directory has been created, Drupal cannot be deployed
remote: hot_deploy_added=false
remote: MySQL already running
remote: Done
remote: Running .openshift/action_hooks/post_deploy

Expected results:
drush successfully installed

Additional info:
When i install it manually from ssh it works:
[drupal01-rclsilver.devel.cloud.rclsilver.net ~]\> pear channel-discover pear.drush.org
no write access to /var/lib/openshift/5193e4c38e005936e60000ef/.pearrc!
[drupal01-rclsilver.devel.cloud.rclsilver.net ~]\> pear channel-discover pear.drush.org
Channel "pear.drush.org" is already initialized
[drupal01-rclsilver.devel.cloud.rclsilver.net ~]\> pear install pear.drush.org/drush
downloading drush-5.9.0.tgz ...
Starting to download drush-5.9.0.tgz (412,079 bytes)
....................................................................................done: 412,079 bytes
install ok: channel://pear.drush.org/drush-5.9.0
[drupal01-rclsilver.devel.cloud.rclsilver.net ~]\> php-5.3/phplib/pear/pear/drush version
drush version 5.9
Comment 1 Clayton Coleman 2013-05-16 10:00:33 EDT
This looks like drush is down temporarily, but sending over to the node team for more debug.
Comment 2 Clayton Coleman 2013-05-16 10:25:02 EDT
Believe this is related to https://bugzilla.redhat.com/show_bug.cgi?id=963057
Comment 3 Paul Morie 2013-05-28 13:17:52 EDT
I wasn't able to recreate this today:

remote: Stopping PHP cart
remote: [Tue May 28 13:14:16 2013] [warn] module php5_module is already loaded, skipping
remote: Checking pear: pear.drush.org/drush
remote: 
remote: Attempting to discover channel "pear.drush.org"...
remote: downloading channel.xml ...
remote: Starting to download channel.xml (804 bytes)
remote: ....done: 804 bytes
remote: Auto-discovered channel "pear.drush.org", alias "drush", adding to registry
remote: downloading drush-5.9.0.tgz ...
remote: Starting to download drush-5.9.0.tgz (412,079 bytes)
remote: ...done: 412,079 bytes
remote: install ok: channel://pear.drush.org/drush-5.9.0
remote: ERROR: The 'php' directory in your Git repo prevents Drupal from being installed.  Please remove
 'php' and push again.
remote: An error occurred executing 'gear postreceive'
remote: 
remote: For more details about the problem, try running the command again with the '--trace' option.
To ssh://ffdb4624c7b811e2af4f12313d1c59e8@dtest-pmorie171.dev.rhcloud.com/~/git/dtest.git/
   d438822..ec5d30c  master -> master
Comment 4 Dan McPherson 2013-05-29 00:05:25 EDT
If you are verifying this issue you'll want to add the steps:

git rm -r php/
git commit -m 'removing php dir'

before step 4 in the description

Note You need to log in before you can comment on or make changes to this bug.