Bug 963510 - seabios 1.7.2-0.2.gita810e4e7.el7 could not show the 800x640 and 320x240 jpeg pictures
seabios 1.7.2-0.2.gita810e4e7.el7 could not show the 800x640 and 320x240 jpe...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 22:26 EDT by xhan
Modified: 2015-06-16 06:05 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-03 03:06:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xhan 2013-05-15 22:26:27 EDT
Description of problem:

qemu-kvm with seabios 1.7.2-0.2.gita810e4e7.el7 could not show the 
800x640 and 320x240 jpeg pictures.

In the VBE mode info, there are 800x600 and 320x200 modes.

However, if the picture is 800x600, the seabios function jpeg_decode in 
source file src/jpeg.c:jpeg_decode would fail to check because of the 
the decision (jpeg->height & 15).

Version-Release number of selected component (if applicable):

rpm -qa | grep seabios
seabios-bin-1.7.2-0.2.gita810e4e7.el7.noarch

rpm -qa | grep qemu-kvm
qemu-kvm-1.4.0-4.el7.x86_64


How reproducible:
100%

Steps to Reproduce:

1. start qemu-kvm with seabios
   qemu-kvm -bios out/bios.bin -vnc :1 -boot 
menu=on,splash=../j800x640.jpg,splash-time=60000  -vga std  -chardev 
stdio,id=seabios -device isa-debugcon,iobase=0x402,chardev=seabios

2. vncviewer hostip:1

Actual results:
1. 800x640 and 320x240 jpeg pictures could not be showed up.
2. 800x600 could not be displayed.
3. 320x200 jpeg can work

Expected results:
Make sure which kind of the resolution picture mode can work as splash 
image.
And make man page conform to the seabios code.

Additional info:

man qemu-kvm

...

A splash picture could be passed to bios, enabling user to show it as 
logo, when option splash=sp_name is given and menu=on, If
           firmware/BIOS supports them. Currently Seabios for X86 
system support it.  limitation: The splash file could be a jpeg file or 
a BMP file
           in 24 BPP format(true color). The resolution should be 
supported by the SVGA mode, so the recommended is 320x240, 640x480, 800x640.

...
Comment 2 Miroslav Rezanina 2014-01-07 11:42:21 EST
Move to 7.1 as this has to be properly tested and solved upstream.
Comment 5 Gerd Hoffmann 2014-07-02 09:10:52 EDT
Any use case for this?
If not I'd rather go disable splashscreen support in the rhel seabios builds.
Comment 6 juzhang 2014-07-02 21:46:36 EDT
(In reply to Gerd Hoffmann from comment #5)
> Any use case for this?
> If not I'd rather go disable splashscreen support in the rhel seabios builds.

Xhan has left RedHat. From kvm qe pov, we do not see any real use case for this.
It's ok disable splashscreen support.

Best Regards,
Junyi
Comment 7 Gerd Hoffmann 2014-07-03 03:06:48 EDT
Oh, I see it is disabled already.  Nothing to do ;)

Note You need to log in before you can comment on or make changes to this bug.