Bug 963512 - Cmd rpcinfo usage info is not correct. And the two usage info from 'rpcinfo -h' and man page are inconsistent.
Cmd rpcinfo usage info is not correct. And the two usage info from 'rpcinfo ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpcbind (Show other bugs)
7.0
All Linux
low Severity low
: rc
: 7.0
Assigned To: Steve Dickson
Yin.JianHong
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-15 22:46 EDT by Yin.JianHong
Modified: 2015-03-05 06:22 EST (History)
2 users (show)

See Also:
Fixed In Version: rpcbind-0.2.0-25.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-05 06:22:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yin.JianHong 2013-05-15 22:46:13 EDT
Description of problem:
The two usage info from 'rpcinfo -h' and man page  are inconsistent.

Version-Release number of selected component (if applicable):
rpcbind-0.2.0-19
rpcbind-0.2.0-20

How reproducible:
always

Steps to Reproduce:
1.rpcinfo -h
2.man rpcinfo | head -n17
3.
  
Actual results:
the two is difference.

Expected results:
you known

Additional info:
in the man page.
 rpcinfo -l [-T transport] host prognum [versnum]  # the versnum is optional
 but in fact it is wrong.

 please check others.
  Be sure the usage in man page and code consistent, and correct.
Comment 2 Yin.JianHong 2013-05-15 22:50:49 EDT
The screen log:

# rpcinfo -h
rpcinfo: invalid option -- 'h'
Usage: rpcinfo [-m | -s] [host]
       rpcinfo -p [host]
       rpcinfo -T netid host prognum [versnum]
       rpcinfo -l host prognum versnum
       rpcinfo [-n portnum] -u | -t host prognum [versnum]
       rpcinfo -a serv_address -T netid prognum [version]
       rpcinfo -b prognum versnum
       rpcinfo -d [-T netid] prognum versnum
# man rpcinfo | head -n17
RPCINFO(8)                                       BSD System Manager's Manual                                       RPCINFO(8)

NAME
     rpcinfo — report RPC information

SYNOPSIS
     rpcinfo [-m | -s] [host]
     rpcinfo -p [host]
     rpcinfo -T transport host prognum [versnum]
     rpcinfo -l [-T transport] host prognum [versnum]
     rpcinfo [-n portnum] -u host prognum [versnum]
     rpcinfo [-n portnum] [-t] host prognum [versnum]
     rpcinfo -a serv_address -T transport prognum [versnum]
     rpcinfo -b [-T transport] prognum versnum
     rpcinfo -d [-T transport] prognum versnum

DESCRIPTION
Comment 3 CAI Qian 2013-08-29 03:29:52 EDT
Easy fix. Can you attach a patch?
Comment 4 Yin.JianHong 2013-08-29 03:55:22 EDT
(In reply to CAI Qian from comment #3)
> Easy fix. Can you attach a patch?

oh, sorry recently no;
I have no time to fix these mistake. why our developer not?
There are many cases I need to write,, and errata, and new testplan  please..
Comment 5 RHEL Product and Program Management 2014-03-22 02:51:36 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 9 Steve Dickson 2014-09-22 08:51:06 EDT
ommit 6e67b1e5e3a36649ad05829f8bae9d2a9e703594
Author: Steve Dickson <steved@redhat.com>
Date:   Mon Sep 22 08:49:08 2014 -0400

    rpcinfo: Fixed typo in rpcinfo man page
    
    Signed-off-by: Steve Dickson <steved@redhat.com>
Comment 11 Yin.JianHong 2014-11-07 05:52:37 EST
[root@rdma-qe-11 ~]# rpm -q rpcbind 
rpcbind-0.2.0-25.el7.x86_64
[root@rdma-qe-11 ~]# rpcinfo -h
rpcinfo: invalid option -- 'h'
Usage: rpcinfo [-m | -s] [host]
       rpcinfo -p [host]
       rpcinfo -T netid host prognum [versnum]
       rpcinfo -l host prognum versnum
       rpcinfo [-n portnum] -u | -t host prognum [versnum]
       rpcinfo -a serv_address -T netid prognum [version]
       rpcinfo -b prognum versnum
       rpcinfo -d [-T netid] prognum versnum
[root@rdma-qe-11 ~]#  man rpcinfo | head -n17
RPCINFO(8)                                                               BSD System Manager's Manual                                                              RPCINFO(8)

NAME
     rpcinfo — report RPC information

SYNOPSIS
     rpcinfo [-m | -s] [host]
     rpcinfo -p [host]
     rpcinfo -T transport host prognum [versnum]
     rpcinfo -l [-T transport] host prognum versnum
     rpcinfo [-n portnum] -u host prognum [versnum]
     rpcinfo [-n portnum] [-t] host prognum [versnum]
     rpcinfo -a serv_address -T transport prognum [versnum]
     rpcinfo -b [-T transport] prognum versnum
     rpcinfo -d [-T transport] prognum versnum

DESCRIPTION
Comment 13 errata-xmlrpc 2015-03-05 06:22:09 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0489.html

Note You need to log in before you can comment on or make changes to this bug.