Bug 963533 - SELinux is preventing /usr/lib64/dbus-1/dbus-daemon-launch-helper from 'connectto' accesses on the unix_stream_socket /var/lib/sss/pipes/nss.
SELinux is preventing /usr/lib64/dbus-1/dbus-daemon-launch-helper from 'conne...
Status: CLOSED DUPLICATE of bug 801173
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:4ce084f9863055131b9a23751cb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 01:29 EDT by Vít Ondruch
Modified: 2013-05-16 01:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-16 01:50:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vít Ondruch 2013-05-16 01:29:32 EDT
Description of problem:
SELinux is preventing /usr/lib64/dbus-1/dbus-daemon-launch-helper from 'connectto' accesses on the unix_stream_socket /var/lib/sss/pipes/nss.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that dbus-daemon-launch-helper should be allowed connectto access on the nss unix_stream_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep dbus-daemon-lau /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:system_dbusd_t:s0-s0:c0.c1023
Target Context                unconfined_u:system_r:unconfined_t:s0-s0:c0.c1023
Target Objects                /var/lib/sss/pipes/nss [ unix_stream_socket ]
Source                        dbus-daemon-lau
Source Path                   /usr/lib64/dbus-1/dbus-daemon-launch-helper
Port                          <Neznámé>
Host                          (removed)
Source RPM Packages           dbus-1.6.8-5.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-44.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.1-301.fc19.x86_64 #1 SMP Wed
                              May 8 18:02:34 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-05-16 07:24:16 CEST
Last Seen                     2013-05-16 07:24:33 CEST
Local ID                      6428eeff-577b-470a-873a-5cb53101c9b2

Raw Audit Messages
type=AVC msg=audit(1368681873.553:444): avc:  denied  { connectto } for  pid=3343 comm="dbus-daemon-lau" path="/var/lib/sss/pipes/nss" scontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tcontext=unconfined_u:system_r:unconfined_t:s0-s0:c0.c1023 tclass=unix_stream_socket


type=SYSCALL msg=audit(1368681873.553:444): arch=x86_64 syscall=connect success=no exit=EACCES a0=3 a1=7ffff5b5ea70 a2=6e a3=7ffff5b5e740 items=0 ppid=3342 pid=3343 auid=4294967295 uid=81 gid=81 euid=0 suid=0 fsuid=0 egid=81 sgid=81 fsgid=81 ses=4294967295 tty=(none) comm=dbus-daemon-lau exe=/usr/lib64/dbus-1/dbus-daemon-launch-helper subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 key=(null)

Hash: dbus-daemon-lau,system_dbusd_t,unconfined_t,unix_stream_socket,connectto

audit2allow

#============= system_dbusd_t ==============
allow system_dbusd_t unconfined_t:unix_stream_socket connectto;

audit2allow -R
require {
	type system_dbusd_t;
}

#============= system_dbusd_t ==============
unconfined_stream_connect(system_dbusd_t)


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.1-301.fc19.x86_64
type:           libreport

Potential duplicate: bug 801173
Comment 1 Miroslav Grepl 2013-05-16 01:50:49 EDT

*** This bug has been marked as a duplicate of bug 801173 ***

Note You need to log in before you can comment on or make changes to this bug.