Bug 963540 - [FEATURE] Enhance logging in protocol server
[FEATURE] Enhance logging in protocol server
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: protocol (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raghavendra G
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 02:22 EDT by Raghavendra G
Modified: 2013-07-24 13:48 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:48:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra G 2013-05-16 02:22:55 EDT
Description of problem:
Currently we log the tuple (server-xlator-name, callid) for identifying
a call in log messages. However it does not uniquely identify the operation when there
are multiple clients (since operations from all clients go through same
server). Adding connection-id resolves this ambiguity.
Also printing connection-id helps diagnoise failures associated with
connection state (like fds, locks).

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2013-05-16 02:24:48 EDT
REVIEW: http://review.gluster.org/5011 (protocol/server: print connection-id in fop failure logs.) posted (#3) for review on master by Raghavendra G (raghavendra@gluster.com)
Comment 2 Anand Avati 2013-06-04 22:01:52 EDT
REVIEW: http://review.gluster.org/5011 (protocol/server: print connection-id in fop failure logs.) posted (#4) for review on master by Raghavendra G (raghavendra@gluster.com)
Comment 3 Anand Avati 2013-06-04 23:50:11 EDT
REVIEW: http://review.gluster.org/5147 (just a test Signed-off-by: jian.hou <hjimmy19870806@gmail.com>) posted (#1) for review on release-3.4 by 健 侯 (hjimmy19870806@gmail.com)
Comment 4 Anand Avati 2013-06-04 23:51:08 EDT
REVIEW: http://review.gluster.org/5147 (just a test) posted (#2) for review on release-3.4 by 健 侯 (hjimmy19870806@gmail.com)
Comment 5 Anand Avati 2013-06-19 02:27:54 EDT
COMMIT: http://review.gluster.org/5011 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 1d6f6a65d76f0e8dc9b62fdae305b6246ce268c5
Author: Raghavendra G <raghavendra@gluster.com>
Date:   Wed May 15 15:54:29 2013 +0530

    protocol/server: print connection-id in fop failure logs.
    
    Currently we have tuple (server-xlator-name, callid) for identifying
    a call. However it does not uniquely identify the operation when there
    are multiple clients (since operations from all clients go through same
    server). Adding connection-id resolves this ambiguity.
    Also printing connection-id helps diagnose failures associated with
    connection state (like fds, locks).
    
    Change-Id: I13563bd06ee9b72fc1a10d239f77db5183658573
    BUG: 963540
    Signed-off-by: Raghavendra G <raghavendra@gluster.com>
    Reviewed-on: http://review.gluster.org/5011
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Note You need to log in before you can comment on or make changes to this bug.