Bug 963706 - lyx needs to require librsvg2-tools to handle SVG files on F19+
lyx needs to require librsvg2-tools to handle SVG files on F19+
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: lyx (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 08:31 EDT by Felix Kaechele
Modified: 2014-02-10 08:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-06 12:01:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Kaechele 2013-05-16 08:31:45 EDT
In F19+ rsvg-convert was moved from librsvg2 to librsvg2-tools. Lyx needs rsvg-convert in order to process SVG images.
Therefor lyx needs to require librsvg2-tools.
Comment 1 José Matos 2014-02-05 17:25:55 EST
The convert tool from ImageMagick already supports svg, or is there a quality problem with converts conversions? (no pun intended) :-)

We can add librsvg2-tools as a requirement but before doing that I would like to have compelling reasons.
Comment 2 Felix Kaechele 2014-02-06 12:01:46 EST
I just tested this and it seems that this is no longer an issue.
From what I remember the original problem was that SVG previews would not render when librsvg2-tools was not installed.
Comment 3 José Matos 2014-02-10 08:53:12 EST
Thank you for the note. :-)

If lyx finds rsvg-convert present it will use it, if not it will fall back to convert (from ImageMagick) as the default converter. So I think that for the moment there is no need to require librsvg2-tools.

In any case with your bug report I took the chance to install librsvg2-tools :-) .

Note You need to log in before you can comment on or make changes to this bug.