Bug 963806 - [RHSC] vdsm: Failed to define network filters on libvirt[FAILED] during add host
[RHSC] vdsm: Failed to define network filters on libvirt[FAILED] during add host
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: vdsm (Show other bugs)
2.1
Unspecified Unspecified
high Severity urgent
: ---
: ---
Assigned To: Bala.FA
Matt Mahoney
infra
:
: 980056 (view as bug list)
Depends On: 953504
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 11:10 EDT by Matt Mahoney
Modified: 2015-11-22 21:57 EST (History)
14 users (show)

See Also:
Fixed In Version: vdsm-4.10.2-22.7.el6rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:26:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Mahoney 2013-05-16 11:10:51 EDT
Description of problem:
The VDSM version in RHS build 20130515.n.0 does not allow server to be added via RHSC bb1 

Work around:

 - Remove vdsm rpms.
 - Install VDSM from rhsc/bb1 repo.

Version-Release number of selected component (if applicable):

RHSC: bb1
RHS: http://rhsqe-repo.lab.eng.blr.redhat.com/iso/rhs2.1/RHS-2.1-20130515.n.0-RHS-x86_64-DVD1.iso

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 3 Sahina Bose 2013-05-17 06:28:47 EDT
Matt, can you provide the version of vdsm after reinstalling or the repo that you have configured?
Comment 4 Matt Mahoney 2013-05-17 09:48:59 EDT
Created a new 20130515.n.0 VM, and the did the following:

rpm -qa | grep vdsm
vdsm-python-4.10.2-18.0.1.el6rhs.x86_64
vdsm-gluster-4.10.2-18.0.1.el6rhs.noarch
vdsm-xmlrpc-4.10.2-18.0.1.el6rhs.noarch
vdsm-cli-4.10.2-18.0.1.el6rhs.noarch
vdsm-4.10.2-18.0.1.el6rhs.x86_64
vdsm-reg-4.10.2-18.0.1.el6rhs.noarch

service vdsmd status
VDS daemon is not running


service vdsmd start
vdsm: libvirt already configured for vdsm                  [  OK  ]
Starting iscsid: 
vdsm: Failed to define network filters on libvirt          [FAILED]
Comment 5 Timothy Asir 2013-05-30 05:30:22 EDT
Hope the system received the following error messages in /var/log/libvirt.log

...
2013-05-30 08:50:26.935+0000: 1839: error : virNetSASLSessionServerStep:614 : authentication failed: Failed to start SASL negotiation: -20 (SASL(-13): user not found: no secret in database)
2013-05-30 08:50:26.935+0000: 1839: error : remoteDispatchAuthSaslStep:2750 : authentication failed: authentication failed
...

By observing the above log messages; it's clear that its failed with an authentication error.

Quick fix:
~~~~~~~~~~

Just run the following commands:

   1) vdsm-tool set-saslpasswd
   2) service vdsmd restart
Comment 6 Dan Kenigsberg 2013-06-05 18:13:00 EDT
Which version of vdsm was removed? This bug could be a dup of bug 902346.
Comment 7 Sahina Bose 2013-06-11 04:45:22 EDT
Dan, the error appears on installing vdsm from RHS 2.1 ISO.
And was fixed as per comment 5.
Comment 8 Matt Mahoney 2013-06-28 12:04:38 EDT
Failed to verify. This fix apparently did not make it into the last RHS ISO. 

RHSC: bb4
RHS: RHS-2.1-20130628.n.0-RHS-x86_64-DVD1.iso

After running the quick-fix commands mentioned in comment-5, the server added with no failures.

Please reset to on_qa once the RHS iso has the proper fix.
Comment 10 Prasanth 2013-07-08 08:30:04 EDT
Following are the specific errors seen in host-deploy logs:

------
2013-07-08 07:36:09 DEBUG otopi.plugins.otopi.services.rhel plugin.execute:412 execute-output: ('/sbin/service', 'vdsmd', 'start') stdout:
vdsm: libvirt already configured for vdsm [  OK  ]
Starting iscsid: 
vdsm: Failed to define network filters on libvirt[FAILED]

2013-07-08 07:36:09 DEBUG otopi.plugins.otopi.services.rhel plugin.execute:417 execute-output: ('/sbin/service', 'vdsmd', 'start') stderr:


2013-07-08 07:36:09 DEBUG otopi.context context._executeMethod:130 method exception
Traceback (most recent call last):
  File "/tmp/ovirt-Ex1iY6m70O/pythonlib/otopi/context.py", line 120, in _executeMethod
    method['method']()
  File "/tmp/ovirt-Ex1iY6m70O/otopi-plugins/ovirt-host-deploy/vdsm/packages.py", line 153, in _start
    self.services.state('vdsmd', True)
  File "/tmp/ovirt-Ex1iY6m70O/otopi-plugins/otopi/services/rhel.py", line 184, in state
    'start' if state else 'stop'
  File "/tmp/ovirt-Ex1iY6m70O/otopi-plugins/otopi/services/rhel.py", line 96, in _executeServiceCommand
    raiseOnError=raiseOnError
  File "/tmp/ovirt-Ex1iY6m70O/pythonlib/otopi/plugin.py", line 422, in execute
    command=args[0],
RuntimeError: Command '/sbin/service' failed to execute
2013-07-08 07:36:09 ERROR otopi.context context._executeMethod:139 Failed to execute stage 'Closing up': Command '/sbin/service' failed to execute
-------
Comment 11 Bala.FA 2013-07-09 06:18:02 EDT
'vdsm-tool set-saslpasswd' command in post of vdsm.rpm fails during installation time of RHS.  This is because the installer runs in selinux enabled mode whereas RHS has no selinux policy (note: RHS runs with selinux disabled).  vdsm-tool crashes on 'import seobject' ie it fails on every call.

Acceptable solution is avoid using vdsm-tool in spec file scriptlets and run appropriate command till RHS supports selinux
Comment 12 Bala.FA 2013-07-09 08:20:00 EDT
Workaround is to run RHS installation with 'selinux=0' in ISO boot.
Comment 13 Bala.FA 2013-07-09 08:45:34 EDT
Patch is under review
https://code.engineering.redhat.com/gerrit/9944
Comment 14 Sahina Bose 2013-07-16 04:18:05 EDT
*** Bug 980056 has been marked as a duplicate of this bug. ***
Comment 15 Matt Mahoney 2013-07-17 15:29:20 EDT
Verified fixed bb6 & RHS-2.1-20130717.
Comment 16 Scott Haines 2013-09-23 18:26:01 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.