Bug 963808 - [abrt] gnome-shell-3.6.3.1-1.fc18: type_to_string: Process /usr/bin/gnome-shell was killed by signal 6 (SIGABRT)
[abrt] gnome-shell-3.6.3.1-1.fc18: type_to_string: Process /usr/bin/gnome-she...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-bluetooth (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
abrt_hash:207b57b02d6feeaec9849393626...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 11:14 EDT by Markus Mayer
Modified: 2013-05-26 11:26 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-18 08:13:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (241.65 KB, text/plain)
2013-05-16 11:14 EDT, Markus Mayer
no flags Details
File: cgroup (129 bytes, text/plain)
2013-05-16 11:15 EDT, Markus Mayer
no flags Details
File: core_backtrace (10.86 KB, text/plain)
2013-05-16 11:15 EDT, Markus Mayer
no flags Details
File: dso_list (20.02 KB, text/plain)
2013-05-16 11:15 EDT, Markus Mayer
no flags Details
File: environ (1.45 KB, text/plain)
2013-05-16 11:15 EDT, Markus Mayer
no flags Details
File: limits (1.29 KB, text/plain)
2013-05-16 11:15 EDT, Markus Mayer
no flags Details
File: maps (79.03 KB, text/plain)
2013-05-16 11:15 EDT, Markus Mayer
no flags Details
File: open_fds (4.64 KB, text/plain)
2013-05-16 11:15 EDT, Markus Mayer
no flags Details
File: proc_pid_status (934 bytes, text/plain)
2013-05-16 11:15 EDT, Markus Mayer
no flags Details
File: var_log_messages (1.14 KB, text/plain)
2013-05-16 11:15 EDT, Markus Mayer
no flags Details
File: xsession_errors (270 bytes, text/plain)
2013-05-16 11:15 EDT, Markus Mayer
no flags Details

  None (edit)
Description Markus Mayer 2013-05-16 11:14:44 EDT
Description of problem:
This happens directly after logging into gnome.

Happens since upgrade to 3.9.2-200.fc18.x86_64; 3.8.11-200.fc18.x86_64 works fine

Version-Release number of selected component:
gnome-shell-3.6.3.1-1.fc18

Additional info:
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: type_to_string
executable:     /usr/bin/gnome-shell
kernel:         3.9.2-200.fc18.x86_64
uid:            1000
ureports_counter: 2

Truncated backtrace:
Thread no. 1 (10 frames)
 #3 type_to_string at rfkill-glib.c:83
 #5 rfkill_glib_open at rfkill-glib.c:232
 #6 bluetooth_killswitch_init at bluetooth-killswitch.c:344
 #7 g_type_create_instance at gtype.c:1890
 #8 g_object_constructor at gobject.c:1854
 #11 bluetooth_killswitch_new at bluetooth-killswitch.c:386
 #12 bluetooth_applet_init at bluetooth-applet.c:960
 #13 g_type_create_instance at gtype.c:1890
 #14 g_object_constructor at gobject.c:1854
 #16 object_instance_init at gi/object.c:948
Comment 1 Markus Mayer 2013-05-16 11:14:58 EDT
Created attachment 748887 [details]
File: backtrace
Comment 2 Markus Mayer 2013-05-16 11:15:06 EDT
Created attachment 748888 [details]
File: cgroup
Comment 3 Markus Mayer 2013-05-16 11:15:11 EDT
Created attachment 748889 [details]
File: core_backtrace
Comment 4 Markus Mayer 2013-05-16 11:15:16 EDT
Created attachment 748890 [details]
File: dso_list
Comment 5 Markus Mayer 2013-05-16 11:15:19 EDT
Created attachment 748891 [details]
File: environ
Comment 6 Markus Mayer 2013-05-16 11:15:21 EDT
Created attachment 748892 [details]
File: limits
Comment 7 Markus Mayer 2013-05-16 11:15:26 EDT
Created attachment 748893 [details]
File: maps
Comment 8 Markus Mayer 2013-05-16 11:15:33 EDT
Created attachment 748894 [details]
File: open_fds
Comment 9 Markus Mayer 2013-05-16 11:15:35 EDT
Created attachment 748895 [details]
File: proc_pid_status
Comment 10 Markus Mayer 2013-05-16 11:15:39 EDT
Created attachment 748896 [details]
File: var_log_messages
Comment 11 Markus Mayer 2013-05-16 11:15:45 EDT
Created attachment 748897 [details]
File: xsession_errors
Comment 12 Florian Müllner 2013-05-16 12:00:20 EDT
This was fixed upstream in gnome-bluetooth just today :-)
Reassigning ...
Comment 13 Markus Mayer 2013-05-18 08:13:48 EDT
Just installed gnome-bluetooth-3.6.1-3.fc18 and it solves my issue. Will this fix be ported to fc19, too?

Note You need to log in before you can comment on or make changes to this bug.