Bug 963837 - The short form of option placed before sub-command are not accepted
The short form of option placed before sub-command are not accepted
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: realmd (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stef Walter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 12:35 EDT by Patrik Kis
Modified: 2013-07-19 12:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-19 12:37:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrik Kis 2013-05-16 12:35:57 EDT
Description of problem:
It matters where options are placed after realm command line tool, i.e. before or after a sub-command. Short forms and long forms without equal mark (=) works only after sub-command. It may be quite confusing.

Version-Release number of selected component (if applicable):
realmd-0.14.1-1.fc19

How reproducible:
always

Steps to Reproduce:

This works:

# realm --user=Bender join ad.baseos.qe
Password for Bender: 
#

.... but

# realm --user Bender join ad.baseos.qe
 realm discover -v [realm-name]
   Discover available realm

 realm join -v [-U user] realm-name
   Enroll this machine in a realm

 realm leave -v [-U user] [realm-name]
   Unenroll this machine from a realm

 realm list
   List known realms

 realm permit [-ax] [-R realm] user ...
   Permit user logins

 realm deny --all [-R realm]
   Deny user logins
# realm -U Bender join ad.baseos.qe
 realm discover -v [realm-name]
   Discover available realm

 realm join -v [-U user] realm-name
   Enroll this machine in a realm

 realm leave -v [-U user] [realm-name]
   Unenroll this machine from a realm

 realm list
   List known realms

 realm permit [-ax] [-R realm] user ...
   Permit user logins

 realm deny --all [-R realm]
   Deny user logins



.... and again, but different order

# realm join --user Bender ad.baseos.qe
Password for Bender: 
#
# realm join -U Bender ad.baseos.qe
Password for Bender: 
#
# realm join --user=Bender ad.baseos.qe
Password for Bender:
Comment 1 Stef Walter 2013-05-17 11:00:58 EDT
Indeed, it seems to be trying to use 'Bender' as the command name, instead of 'join'.
Comment 2 Patrik Kis 2013-07-18 05:57:09 EDT
Hi Stef,

Any plans with this bug? It is not important for me at all and it is clear that I placed the command arguments in wrong order. On the other hand if it can be easily fixed, why not. If cannot be, feel free to close it.
Comment 3 Stef Walter 2013-07-19 12:37:02 EDT
It's very awkward to fix. I think the equals sign is the preferred form on Linux. Yes, let's close the bug.

Note You need to log in before you can comment on or make changes to this bug.