Bug 963925 - weston: undefined reference to wl_set_buffer_transform at clients/window.c:1381
weston: undefined reference to wl_set_buffer_transform at clients/window.c:1381
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: weston (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-16 15:12 EDT by mulhern@gmail.com
Modified: 2013-05-17 07:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-17 07:52:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mulhern@gmail.com 2013-05-16 15:12:11 EDT
Description of problem: undefined reference to wl_set_buffer_transform at clients/window.c:1381 error during link phase. Also, implicit definition of wl_set_buffer_transform warning during compilation.


Version-Release number of selected component (if applicable): 1.1.0 and current git clone


How reproducible: Easy


Steps to Reproduce:
1. "find . -name '*.c' -exec grep -l "wl_surface_set_buffer_transform" {} \;" matches the procedure invocation, but no definition
2. "find . -name '*.h' -exec grep -l "wl_surface_set_buffer_transform" {} \;" matches nothing
  
Actual results: Couldn't build 1.1.0 release for yocto project due to linker error.


Expected results: Successful build of 1.1.0 release for yocto project.


Additional info: Building for default qemux86 build in yocto.
Comment 1 mulhern@gmail.com 2013-05-17 07:30:35 EDT
Description is incomplete. Doing further investigation and will update some time today.
Comment 2 mulhern@gmail.com 2013-05-17 07:52:40 EDT
Not a real problem. Behavior caused by wayland and weston releases not being updated together.

Note You need to log in before you can comment on or make changes to this bug.