Bug 964022 - The existing pages of a JBossAS application become blank after making some changes on them and git-pushing only once
The existing pages of a JBossAS application become blank after making some ch...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Dan Mace
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-17 01:18 EDT by Zhe Wang
Modified: 2015-05-14 19:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 00:05:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhe Wang 2013-05-17 01:18:59 EDT
Description of problem:
Given a JBossAS application, after making some changes in its existing pages (e.g, index.html and snoop.jsp) and pushing them to its repo, the changes do not take effect. Moreover, the existing become blank. However, when pushing the changes with a second try, the pages are accessible.

On the other hand, there is no such problem when creating a new page.

Version-Release number of selected component (if applicable):
devenv_3235

How reproducible:
always

Steps to Reproduce:
1. create a JBossAS application
rhc app create as jbossas-7

2.  make some changes to its existing pages, for example, the example pages, index.html and snoop.jsp. In my test, I simply changed the titles of these two pages.

3. push the changes

4. visit the pages URL to check if the changes take effect, e.g.,
<AppDNS>/index.html

5. make some changes different from those in Step 4 (e.g., touch a new file) and push them again

6. check the page in Step 4 is accessible
  
Actual results:
In step 4, both the index.html and snoop.jsp pages become blank. However, the pages becomes accessible in Step 6.

Expected results:
Changes in existing pages of a JBossAS application should take effect with one git-push.

Additional info:
Comment 1 Dan Mace 2013-05-17 13:48:40 EDT
Please re-test in devenv_3239+; couldn't reproduce this.
Comment 2 Dan Mace 2013-05-17 13:49:16 EDT
If it's able to be reproduced in devenv_3239, please provide the full build output for analysis. Thanks!
Comment 3 Zhe Wang 2013-05-20 05:22:58 EDT
Move this bug to VERIFIED, since it is unable to be reproduced in devenv_3247.

Note You need to log in before you can comment on or make changes to this bug.