Bug 964033 - Yum upgrade failed - ModemManager
Yum upgrade failed - ModemManager
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ModemManager (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 964174 964211 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-17 02:07 EDT by Robin Hack
Modified: 2013-05-22 18:01 EDT (History)
9 users (show)

See Also:
Fixed In Version: ModemManager-0.7.990-2.git20130515.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-22 15:04:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Hack 2013-05-17 02:07:21 EDT
[root@openlmi rhack]# yum upgrade
Loaded plugins: auto-update-debuginfo, langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package ModemManager.x86_64 0:0.6.0.0-3.fc19 will be updated
---> Package ModemManager.x86_64 0:0.7.990-1.git20130515.fc20 will be an update
--> Processing Dependency: libqmi-glib.so.0()(64bit) for package: ModemManager-0.7.990-1.git20130515.fc20.x86_64
--> Processing Dependency: libmm-glib.so.0()(64bit) for package: ModemManager-0.7.990-1.git20130515.fc20.x86_64
---> Package NetworkManager.x86_64 1:0.9.8.1-2.git20130507.fc20 will be updated
---> Package NetworkManager.x86_64 1:0.9.9.0-2.git20130515.fc20 will be an update
---> Package NetworkManager-devel.x86_64 1:0.9.8.1-2.git20130507.fc20 will be updated
---> Package NetworkManager-devel.x86_64 1:0.9.9.0-2.git20130515.fc20 will be an update
---> Package NetworkManager-glib.x86_64 1:0.9.8.1-2.git20130507.fc20 will be updated
---> Package NetworkManager-glib.x86_64 1:0.9.9.0-2.git20130515.fc20 will be an update
---> Package NetworkManager-glib-devel.x86_64 1:0.9.8.1-2.git20130507.fc20 will be updated
---> Package NetworkManager-glib-devel.x86_64 1:0.9.9.0-2.git20130515.fc20 will be an update
---> Package anaconda.x86_64 0:19.25-1.fc20 will be updated
---> Package anaconda.x86_64 0:19.27-1.fc20 will be an update
---> Package anaconda-widgets.x86_64 0:19.25-1.fc20 will be updated
---> Package anaconda-widgets.x86_64 0:19.27-1.fc20 will be an update
---> Package cim-schema.noarch 0:2.33.0-4.fc19 will be updated
---> Package cim-schema.noarch 0:2.33.0-5.fc20 will be an update
---> Package cups.x86_64 1:1.7-0.2.b1.fc20 will be updated
---> Package cups.x86_64 1:1.7-0.3.b1.fc20 will be an update
---> Package cups-filesystem.noarch 1:1.7-0.2.b1.fc20 will be updated
---> Package cups-filesystem.noarch 1:1.7-0.3.b1.fc20 will be an update
---> Package cups-filters.x86_64 0:1.0.34-1.fc20 will be updated
---> Package cups-filters.x86_64 0:1.0.34-3.fc20 will be an update
---> Package cups-filters-libs.x86_64 0:1.0.34-1.fc20 will be updated
---> Package cups-filters-libs.x86_64 0:1.0.34-3.fc20 will be an update
---> Package cups-libs.x86_64 1:1.7-0.2.b1.fc20 will be updated
---> Package cups-libs.x86_64 1:1.7-0.3.b1.fc20 will be an update
---> Package file.x86_64 0:5.14-5.fc20 will be updated
---> Package file.x86_64 0:5.14-6.fc20 will be an update
---> Package file-libs.x86_64 0:5.14-5.fc20 will be updated
---> Package file-libs.x86_64 0:5.14-6.fc20 will be an update
---> Package gnu-free-fonts-common.noarch 0:20120503-5.fc19 will be updated
---> Package gnu-free-fonts-common.noarch 0:20120503-6.fc20 will be an update
---> Package gnu-free-mono-fonts.noarch 0:20120503-5.fc19 will be updated
---> Package gnu-free-mono-fonts.noarch 0:20120503-6.fc20 will be an update
---> Package gnu-free-sans-fonts.noarch 0:20120503-5.fc19 will be updated
---> Package gnu-free-sans-fonts.noarch 0:20120503-6.fc20 will be an update
---> Package gnu-free-serif-fonts.noarch 0:20120503-5.fc19 will be updated
---> Package gnu-free-serif-fonts.noarch 0:20120503-6.fc20 will be an update
---> Package gnupg2.x86_64 0:2.0.19-8.fc19 will be updated
---> Package gnupg2.x86_64 0:2.0.20-1.fc20 will be an update
---> Package ibus-kkc.x86_64 0:1.5.12-1.fc20 will be updated
---> Package ibus-kkc.x86_64 0:1.5.13-1.fc20 will be an update
---> Package java-1.7.0-openjdk.x86_64 1:1.7.0.19-2.3.9.8.fc20 will be updated
---> Package java-1.7.0-openjdk.x86_64 1:1.7.0.19-2.3.9.9.fc20 will be an update
---> Package java-1.7.0-openjdk-devel.x86_64 1:1.7.0.19-2.3.9.8.fc20 will be updated
---> Package java-1.7.0-openjdk-devel.x86_64 1:1.7.0.19-2.3.9.9.fc20 will be an update
---> Package kernel.x86_64 0:3.10.0-0.rc1.git5.1.fc20 will be installed
---> Package kernel-devel.x86_64 0:3.10.0-0.rc1.git5.1.fc20 will be installed
---> Package kernel-headers.x86_64 0:3.10.0-0.rc1.git3.1.fc20 will be updated
---> Package kernel-headers.x86_64 0:3.10.0-0.rc1.git5.1.fc20 will be an update
---> Package kernel-modules-extra.x86_64 0:3.10.0-0.rc1.git5.1.fc20 will be installed
---> Package libassuan.x86_64 0:2.0.3-5.fc19 will be updated
---> Package libassuan.x86_64 0:2.1.0-1.fc20 will be an update
---> Package libcacard.x86_64 2:1.4.1-1.fc20 will be updated
---> Package libcacard.x86_64 2:1.4.1-2.fc20 will be an update
--> Processing Dependency: libgfxdr.so.0()(64bit) for package: 2:libcacard-1.4.1-2.fc20.x86_64
--> Processing Dependency: libgfrpc.so.0()(64bit) for package: 2:libcacard-1.4.1-2.fc20.x86_64
--> Processing Dependency: libgfapi.so.0()(64bit) for package: 2:libcacard-1.4.1-2.fc20.x86_64
---> Package libdrm.x86_64 0:2.4.44-2.fc20 will be updated
---> Package libdrm.x86_64 0:2.4.45-1.fc20 will be an update
---> Package libnm-gtk.x86_64 0:0.9.8.1-3.git20130430.fc20 will be updated
---> Package libnm-gtk.x86_64 0:0.9.9.0-1.git20130515.fc20 will be an update
---> Package libwayland-client.x86_64 0:1.1.0-1.fc20 will be updated
---> Package libwayland-client.x86_64 0:1.1.90-0.1.20130515.fc20 will be an update
---> Package libwayland-cursor.x86_64 0:1.1.0-1.fc20 will be updated
---> Package libwayland-cursor.x86_64 0:1.1.90-0.1.20130515.fc20 will be an update
---> Package libwayland-server.x86_64 0:1.1.0-1.fc20 will be updated
---> Package libwayland-server.x86_64 0:1.1.90-0.1.20130515.fc20 will be an update
---> Package mate-file-manager.x86_64 0:1.6.1-2.fc20 will be updated
---> Package mate-file-manager.x86_64 0:1.6.1-3.fc20 will be an update
---> Package mate-file-manager-extensions.x86_64 0:1.6.1-2.fc20 will be updated
---> Package mate-file-manager-extensions.x86_64 0:1.6.1-3.fc20 will be an update
---> Package mesa-dri-drivers.x86_64 0:9.2-0.1.20130514.fc20 will be updated
---> Package mesa-dri-drivers.x86_64 0:9.2-0.3.20130514.fc20 will be an update
---> Package mesa-filesystem.x86_64 0:9.2-0.1.20130514.fc20 will be updated
---> Package mesa-filesystem.x86_64 0:9.2-0.3.20130514.fc20 will be an update
---> Package mesa-libEGL.x86_64 0:9.2-0.1.20130514.fc20 will be updated
---> Package mesa-libEGL.x86_64 0:9.2-0.3.20130514.fc20 will be an update
---> Package mesa-libGL.x86_64 0:9.2-0.1.20130514.fc20 will be updated
---> Package mesa-libGL.x86_64 0:9.2-0.3.20130514.fc20 will be an update
---> Package mesa-libgbm.x86_64 0:9.2-0.1.20130514.fc20 will be updated
---> Package mesa-libgbm.x86_64 0:9.2-0.3.20130514.fc20 will be an update
---> Package mesa-libglapi.x86_64 0:9.2-0.1.20130514.fc20 will be updated
---> Package mesa-libglapi.x86_64 0:9.2-0.3.20130514.fc20 will be an update
---> Package mesa-libxatracker.x86_64 0:9.2-0.1.20130514.fc20 will be updated
---> Package mesa-libxatracker.x86_64 0:9.2-0.3.20130514.fc20 will be an update
---> Package network-manager-applet.x86_64 0:0.9.8.1-3.git20130430.fc20 will be updated
---> Package network-manager-applet.x86_64 0:0.9.9.0-1.git20130515.fc20 will be an update
---> Package nm-connection-editor.x86_64 0:0.9.8.1-3.git20130430.fc20 will be updated
---> Package nm-connection-editor.x86_64 0:0.9.9.0-1.git20130515.fc20 will be an update
---> Package openconnect.x86_64 0:4.99-1.fc19 will be updated
---> Package openconnect.x86_64 0:5.00-1.fc20 will be an update
---> Package pax.x86_64 0:3.4-15.fc19 will be updated
---> Package pax.x86_64 0:3.4-16.fc20 will be an update
---> Package polkit.x86_64 0:0.110-4.fc20 will be updated
---> Package polkit.x86_64 0:0.111-1.fc20 will be an update
--> Processing Dependency: libmozjs-17.0.so(mozjs_17.0)(64bit) for package: polkit-0.111-1.fc20.x86_64
--> Processing Dependency: libmozjs-17.0.so()(64bit) for package: polkit-0.111-1.fc20.x86_64
---> Package pykickstart.noarch 0:1.99.30-1.fc20 will be updated
---> Package pykickstart.noarch 0:1.99.31-1.fc20 will be an update
---> Package python-blivet.noarch 0:0.13-1.fc20 will be updated
---> Package python-blivet.noarch 0:0.14-1.fc20 will be an update
---> Package python-magic.x86_64 0:5.14-5.fc20 will be updated
---> Package python-magic.x86_64 0:5.14-6.fc20 will be an update
---> Package qemu-common.x86_64 2:1.4.1-1.fc20 will be updated
---> Package qemu-common.x86_64 2:1.4.1-2.fc20 will be an update
---> Package qemu-kvm.x86_64 2:1.4.1-1.fc20 will be updated
---> Package qemu-kvm.x86_64 2:1.4.1-2.fc20 will be an update
---> Package qemu-system-x86.x86_64 2:1.4.1-1.fc20 will be updated
---> Package qemu-system-x86.x86_64 2:1.4.1-2.fc20 will be an update
---> Package wpa_supplicant.x86_64 1:2.0-2.fc20 will be updated
---> Package wpa_supplicant.x86_64 1:2.0-3.fc20 will be an update
---> Package xkeyboard-config.noarch 0:2.8-2.fc20 will be updated
---> Package xkeyboard-config.noarch 0:2.8-3.fc20 will be an update
---> Package xorg-x11-drv-synaptics.x86_64 0:1.7.1-1.fc20 will be updated
---> Package xorg-x11-drv-synaptics.x86_64 0:1.7.1-2.fc20 will be an update
--> Running transaction check
---> Package ModemManager-glib-devel.x86_64 0:0.7.990-1.git20130515.fc20 will be installed
--> Processing Dependency: ModemManager-devel(x86-64) = 0.7.990-1.git20130515.fc20 for package: ModemManager-glib-devel-0.7.990-1.git20130515.fc20.x86_64
--> Processing Dependency: pkgconfig(ModemManager) for package: ModemManager-glib-devel-0.7.990-1.git20130515.fc20.x86_64
---> Package glusterfs.x86_64 0:3.4.0-0.4.beta1.fc20 will be installed
---> Package glusterfs-api.x86_64 0:3.4.0-0.4.beta1.fc20 will be installed
---> Package libqmi.x86_64 0:1.3.0-1.git20130510.fc20 will be installed
---> Package mozjs17.x86_64 0:17.0.0-3.fc20 will be installed
--> Running transaction check
---> Package ModemManager-devel.x86_64 0:0.7.990-1.git20130515.fc20 will be installed
--> Finished Dependency Resolution
--> Running transaction check
---> Package kernel.x86_64 0:3.10.0-0.rc0.git26.1.fc20 will be erased
---> Package kernel-devel.x86_64 0:3.10.0-0.rc0.git26.1.fc20 will be erased
---> Package kernel-modules-extra.x86_64 0:3.10.0-0.rc0.git26.1.fc20 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                     Arch   Version                      Repository
                                                                           Size
================================================================================
Installing:
 kernel                      x86_64 3.10.0-0.rc1.git5.1.fc20     rawhide   31 M
 kernel-devel                x86_64 3.10.0-0.rc1.git5.1.fc20     rawhide  8.3 M
 kernel-modules-extra        x86_64 3.10.0-0.rc1.git5.1.fc20     rawhide  2.2 M
Updating:
 ModemManager                x86_64 0.7.990-1.git20130515.fc20   rawhide  542 k
 NetworkManager              x86_64 1:0.9.9.0-2.git20130515.fc20 rawhide  1.0 M
 NetworkManager-glib-devel   x86_64 1:0.9.9.0-2.git20130515.fc20 rawhide  486 k
 anaconda                    x86_64 19.27-1.fc20                 rawhide  1.9 M
 cim-schema                  noarch 2.33.0-5.fc20                rawhide  1.1 M
 cups                        x86_64 1:1.7-0.3.b1.fc20            rawhide  1.3 M
 file                        x86_64 5.14-6.fc20                  rawhide   54 k
 gnu-free-mono-fonts         noarch 20120503-6.fc20              rawhide  691 k
 gnu-free-sans-fonts         noarch 20120503-6.fc20              rawhide  1.3 M
 gnu-free-serif-fonts        noarch 20120503-6.fc20              rawhide  2.6 M
 gnupg2                      x86_64 2.0.20-1.fc20                rawhide  1.5 M
 ibus-kkc                    x86_64 1.5.13-1.fc20                rawhide   59 k
 java-1.7.0-openjdk          x86_64 1:1.7.0.19-2.3.9.9.fc20      rawhide   25 M
 java-1.7.0-openjdk-devel    x86_64 1:1.7.0.19-2.3.9.9.fc20      rawhide  9.1 M
 kernel-headers              x86_64 3.10.0-0.rc1.git5.1.fc20     rawhide  868 k
 libcacard                   x86_64 2:1.4.1-2.fc20               rawhide   66 k
 libwayland-cursor           x86_64 1.1.90-0.1.20130515.fc20     rawhide   14 k
 mate-file-manager           x86_64 1.6.1-3.fc20                 rawhide  3.4 M
 mesa-dri-drivers            x86_64 9.2-0.3.20130514.fc20        rawhide   11 M
 mesa-filesystem             x86_64 9.2-0.3.20130514.fc20        rawhide   19 k
 mesa-libEGL                 x86_64 9.2-0.3.20130514.fc20        rawhide   71 k
 mesa-libGL                  x86_64 9.2-0.3.20130514.fc20        rawhide  129 k
 mesa-libxatracker           x86_64 9.2-0.3.20130514.fc20        rawhide  645 k
 network-manager-applet      x86_64 0.9.9.0-1.git20130515.fc20   rawhide  214 k
 nm-connection-editor        x86_64 0.9.9.0-1.git20130515.fc20   rawhide  810 k
 openconnect                 x86_64 5.00-1.fc20                  rawhide  283 k
 pax                         x86_64 3.4-16.fc20                  rawhide   72 k
 polkit                      x86_64 0.111-1.fc20                 rawhide  161 k
 python-magic                x86_64 5.14-6.fc20                  rawhide   29 k
 qemu-kvm                    x86_64 2:1.4.1-2.fc20               rawhide   37 k
 xkeyboard-config            noarch 2.8-3.fc20                   rawhide  698 k
 xorg-x11-drv-synaptics      x86_64 1.7.1-2.fc20                 rawhide   77 k
Removing:
 kernel                      x86_64 3.10.0-0.rc0.git26.1.fc20    @rawhide 132 M
 kernel-devel                x86_64 3.10.0-0.rc0.git26.1.fc20    @rawhide  31 M
 kernel-modules-extra        x86_64 3.10.0-0.rc0.git26.1.fc20    @rawhide 9.1 M
Installing for dependencies:
 ModemManager-devel          x86_64 0.7.990-1.git20130515.fc20   rawhide  176 k
 ModemManager-glib-devel     x86_64 0.7.990-1.git20130515.fc20   rawhide  363 k
 glusterfs                   x86_64 3.4.0-0.4.beta1.fc20         rawhide  2.4 M
 glusterfs-api               x86_64 3.4.0-0.4.beta1.fc20         rawhide   35 k
 libqmi                      x86_64 1.3.0-1.git20130510.fc20     rawhide  273 k
 mozjs17                     x86_64 17.0.0-3.fc20                rawhide  1.3 M
Updating for dependencies:
 NetworkManager-devel        x86_64 1:0.9.9.0-2.git20130515.fc20 rawhide  340 k
 NetworkManager-glib         x86_64 1:0.9.9.0-2.git20130515.fc20 rawhide  321 k
 anaconda-widgets            x86_64 19.27-1.fc20                 rawhide  666 k
 cups-filesystem             noarch 1:1.7-0.3.b1.fc20            rawhide   85 k
 cups-filters                x86_64 1.0.34-3.fc20                rawhide  342 k
 cups-filters-libs           x86_64 1.0.34-3.fc20                rawhide   86 k
 cups-libs                   x86_64 1:1.7-0.3.b1.fc20            rawhide  361 k
 file-libs                   x86_64 5.14-6.fc20                  rawhide  364 k
 gnu-free-fonts-common       noarch 20120503-6.fc20              rawhide  126 k
 libassuan                   x86_64 2.1.0-1.fc20                 rawhide   61 k
 libdrm                      x86_64 2.4.45-1.fc20                rawhide  113 k
 libnm-gtk                   x86_64 0.9.9.0-1.git20130515.fc20   rawhide   74 k
 libwayland-client           x86_64 1.1.90-0.1.20130515.fc20     rawhide   22 k
 libwayland-server           x86_64 1.1.90-0.1.20130515.fc20     rawhide   26 k
 mate-file-manager-extensions
                             x86_64 1.6.1-3.fc20                 rawhide   20 k
 mesa-libgbm                 x86_64 9.2-0.3.20130514.fc20        rawhide   26 k
 mesa-libglapi               x86_64 9.2-0.3.20130514.fc20        rawhide   31 k
 pykickstart                 noarch 1.99.31-1.fc20               rawhide  341 k
 python-blivet               noarch 0.14-1.fc20                  rawhide  467 k
 qemu-common                 x86_64 2:1.4.1-2.fc20               rawhide  217 k
 qemu-system-x86             x86_64 2:1.4.1-2.fc20               rawhide  3.0 M
 wpa_supplicant              x86_64 1:2.0-3.fc20                 rawhide  674 k

Transaction Summary
================================================================================
Install   3 Packages (+ 6 Dependent packages)
Upgrade  32 Packages (+22 Dependent packages)
Remove    3 Packages

Total size: 118 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
ERROR with transaction check vs depsolve:
ModemManager(x86-64) = %{epoch}:0.7.990-1.git20130515.fc20 is needed by ModemManager-glib-devel-0.7.990-1.git20130515.fc20.x86_64
ModemManager-devel(x86-64) = %{epoch}:0.7.990-1.git20130515.fc20 is needed by ModemManager-glib-devel-0.7.990-1.git20130515.fc20.x86_64
ModemManager(x86-64) = %{epoch}:0.7.990-1.git20130515.fc20 is needed by ModemManager-devel-0.7.990-1.git20130515.fc20.x86_64
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
 You could try running: rpm -Va --nofiles --nodigest
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2013-05-17.02-05.PRhpM9.yumtx

How reproducible:
Always
Comment 1 Jan Zeleny 2013-05-17 03:31:08 EDT
Seems like there is problem in the ModemManager spec file (see the %{epoch}:0.7.990-1.git20130515.fc20), reassigning.
Comment 2 Panu Matilainen 2013-05-17 08:34:34 EDT
*** Bug 964174 has been marked as a duplicate of this bug. ***
Comment 3 lnxslck 2013-05-17 09:56:36 EDT
Yes, it seems a problem with ModemManager. After i successfully upgraded to Rawhide, i tried yet again a installation of ModemManager, and it failed like before:

Running transaction check
ERRO com a transação check vs depsolve:
ModemManager(x86-64) = %{epoch}:0.7.990-1.git20130515.fc20 is needed by ModemManager-glib-devel-0.7.990-1.git20130515.fc20.x86_64
ModemManager-devel(x86-64) = %{epoch}:0.7.990-1.git20130515.fc20 is needed by ModemManager-glib-devel-0.7.990-1.git20130515.fc20.x86_64
ModemManager(x86-64) = %{epoch}:0.7.990-1.git20130515.fc20 is needed by ModemManager-devel-0.7.990-1.git20130515.fc20.x86_64
Por favor este erro em https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum
Comment 4 Jan Zeleny 2013-05-17 10:49:54 EDT
*** Bug 964211 has been marked as a duplicate of this bug. ***
Comment 5 poma 2013-05-17 12:01:02 EDT
# rpm -qa ModemManager*
ModemManager-0.7.990-2.git20130515.fc20.i686
ModemManager-glib-devel-0.7.990-2.git20130515.fc20.i686
ModemManager-devel-0.7.990-2.git20130515.fc20.i686

http://koji.fedoraproject.org/koji/buildinfo?buildID=419610
Comment 6 lnxslck 2013-05-17 13:00:25 EDT
(In reply to comment #5)
> # rpm -qa ModemManager*
> ModemManager-0.7.990-2.git20130515.fc20.i686
> ModemManager-glib-devel-0.7.990-2.git20130515.fc20.i686
> ModemManager-devel-0.7.990-2.git20130515.fc20.i686
> 
> http://koji.fedoraproject.org/koji/buildinfo?buildID=419610

Care to elaborate?

I still get the same error, wich repositories need to be active (rawhide-debug-info, rawhide-source)?
Comment 7 poma 2013-05-17 14:03:06 EDT
(In reply to comment #6)

# yum clean all/metadata

/var/log/yum.log
May 17 11:57:45 Installed: libqmi-1.3.0-1.git20130510.fc20.i686
May 17 11:57:46 Updated: ModemManager-0.7.990-2.git20130515.fc20.i686
May 17 11:57:46 Installed: ModemManager-devel-0.7.990-2.git20130515.fc20.i686
May 17 11:57:47 Installed: ModemManager-glib-devel-0.7.990-2.git20130515.fc20.i686
Comment 8 lnxslck 2013-05-20 06:00:43 EDT
The solution presented by poma works, this is what i did:

# yum clean all

# yum clean metada

# yum install libqmi

# yum install ModemManager
Comment 9 poma 2013-05-21 05:54:32 EDT
(In reply to lnxslck from comment #8)

"metada" is a subset of "all" - yum clean.
Therefore if you done 'yum clean all', "metada" has already been done. ;)
Besides,
repoquery --whatrequires libqmi
ModemManager-0:0.7.990-2.git20130515.fc20.i686
…
Therefore 'yum install/update ModemManager' will pull "libqmi" anyway.

Therefore,
yum clean all
yum update ModemManager
will suffice. :)

man 8 yum - comm. clean
man 1 repoquery - pack. yum-utils
Comment 10 Dan Williams 2013-05-22 15:04:42 EDT
Bruno built ModemManager-0.7.990-2.git20130515.fc20 a few days ago to fix the epoch thing.

Note You need to log in before you can comment on or make changes to this bug.