Bug 964111 - LiveCD tools crashes when trying to apply delta to already downloaded rpms
LiveCD tools crashes when trying to apply delta to already downloaded rpms
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-17 05:10 EDT by Arkady L. Shane
Modified: 2013-05-22 16:58 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-22 16:58:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arkady L. Shane 2013-05-17 05:10:27 EDT
I've run livecd-creator some days ago and it downloaded many packages. So now if I run livecd-creator it tries to download deltarpms and apply it to already downloaded. And it crashes.

---
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/repodata/9aa0facf053a3de1f897dd7f2c35b2d8cbe0512efd71230fcc0e34e36ce68eed-prestodelta.xml.gz ...OK
Delta RPMs reduced 103 M of updates to 18 M (82% saved)
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/aisleriot-3.7.91-1.fc19_3.8.0-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/baobab-3.8.1-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/cheese-3.8.1-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/cheese-libs-3.8.1-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/control-center-3.8.1.5-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/eog-3.8.0-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/evolution-3.8.1-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/evolution-data-server-3.8.1-2.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/evolution-ews-3.8.1-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/file-roller-3.8.1-4.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gedit-3.8.1-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/glib-networking-2.36.1-1.fc19_2.36.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/glib2-2.36.1-2.fc19_2.36.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gnome-boxes-3.8.1.2-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gnome-calculator-3.8.1-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gnome-clocks-3.8.1-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gnome-color-manager-3.8.1-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gnome-desktop3-3.8.1-1.fc19_3.8.2-2.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gnome-documents-3.8.1-1.fc19_3.8.2.1-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gnome-icon-theme-3.8.0-1.fc19_3.8.2-1.fc19.noarch.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gnome-icon-theme-symbolic-3.8.0.1-1.fc19_3.8.2.2-1.fc19.noarch.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gnome-online-accounts-3.8.1-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gnome-packagekit-3.8.1-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gnome-screenshot-3.8.1-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gnome-session-3.8.1-2.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gnome-settings-daemon-3.8.1-2.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gnome-settings-daemon-updates-3.8.1-2.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gnome-shell-3.8.1-4.fc19_3.8.2-2.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gnome-shell-extension-common-3.8.1-3.fc19_3.8.2-1.fc19.noarch.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gnome-system-monitor-3.8.0-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gnome-terminal-3.8.1-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gnome-user-docs-3.8.0-1.fc19_3.8.1-1.fc19.noarch.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gsettings-desktop-schemas-3.8.0-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gtk2-2.24.17-1.fc19_2.24.18-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gtk3-3.8.1-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gtk3-immodule-xim-3.8.1-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gtkhtml3-4.6.4-1.fc19_4.6.5-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/gucharmap-3.8.1-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/libgweather-3.8.1-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/libosinfo-0.2.6-1.fc19_0.2.7-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/librsvg2-2.37.0-2.fc19_2.37.0-3.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/mutter-3.8.1-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/pango-1.34.0-1.fc19_1.34.1-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/policycoreutils-2.1.14-37.fc19_2.1.14-40.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/policycoreutils-python-2.1.14-37.fc19_2.1.14-40.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/seahorse-3.8.1-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/selinux-policy-devel-3.12.1-42.fc19_3.12.1-44.fc19.noarch.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/totem-3.8.0-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/totem-mozplugin-3.8.0-1.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/totem-pl-parser-3.4.4-1.fc19_3.4.5-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/vinagre-3.8.1-2.fc19_3.8.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/vte3-0.34.4-1.fc19_0.34.5-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/webkitgtk3-2.0.1-2.fc19_2.0.2-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/xorg-x11-drv-modesetting-0.6.0-6.fc19_0.6.0-7.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/yelp-3.8.0-1.fc19_3.8.1-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/yelp-libs-3.8.0-1.fc19_3.8.1-1.fc19.x86_64.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/drpms/yelp-xsl-3.8.0-1.fc19_3.8.1-1.fc19.noarch.drpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/Packages/c/control-center-filesystem-3.8.2-1.fc19.x86_64.rpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/Packages/f/file-roller-nautilus-3.8.2-1.fc19.x86_64.rpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/Packages/g/gnome-getting-started-docs-3.8.2-1.fc19.noarch.rpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/Packages/g/gnome-icon-theme-legacy-3.8.2-1.fc19.noarch.rpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/Packages/g/gnome-initial-setup-0.10-1.fc19.x86_64.rpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/Packages/g/gnome-session-xsession-3.8.2-1.fc19.x86_64.rpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/Packages/g/gnome-shell-extension-user-theme-3.8.2-1.fc19.noarch.rpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/Packages/g/gtk2-immodule-xim-2.24.18-1.fc19.x86_64.rpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/Packages/l/libgovirt-0.0.3-2.fc19.x86_64.rpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/Packages/p/policycoreutils-devel-2.1.14-40.fc19.x86_64.rpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/Packages/p/policycoreutils-restorecond-2.1.14-40.fc19.x86_64.rpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/Packages/s/selinux-policy-3.12.1-44.fc19.noarch.rpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/Packages/s/selinux-policy-targeted-3.12.1-44.fc19.noarch.rpm ...OK
Retrieving http://mirror.yandex.ru/fedora/linux/development/19/x86_64/os/Packages/t/totem-nautilus-3.8.2-1.fc19.x86_64.rpm ...OK
Finishing delta rebuilds of 53 package(s) (93 M)
umount: /home/ashejn/lives/tmp/imgcreate-v8BZzt/install_root/var/cache/yum: target is busy.
        (In some cases useful info about processes that use
         the device is found by lsof(8) or fuser(1))

Unable to unmount /home/ashejn/lives/tmp/imgcreate-v8BZzt/install_root//var/cache/yum normally, using lazy unmount
lazy umount succeeded on /home/ashejn/lives/tmp/imgcreate-v8BZzt/install_root//var/cache/yum
Unmounting directory /home/ashejn/lives/tmp/imgcreate-v8BZzt/install_root
Losetup remove /dev/loop0
lazy umount succeeded on /home/ashejn/lives/tmp/imgcreate-v8BZzt/install_root//var/cache/yum
Traceback (most recent call last):
  File "/bin/livecd-creator", line 237, in <module>
    sys.exit(main())
  File "/bin/livecd-creator", line 218, in main
    creator.install()
  File "/usr/lib/python2.7/site-packages/imgcreate/creator.py", line 655, in install
    ayum.runInstall()
  File "/usr/lib/python2.7/site-packages/imgcreate/yuminst.py", line 212, in runInstall
    self.downloadPkgs(dlpkgs)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2378, in downloadPkgs
    presto.dequeue_all()
  File "/usr/lib/python2.7/site-packages/yum/drpm.py", line 278, in dequeue_all
    self.progress.start(text='<locally rebuilding deltarpms>', size=total)
TypeError: start() takes at least 3 arguments (1 given)
---
Comment 1 Arkady L. Shane 2013-05-17 09:28:40 EDT
Oh, I examined my script and saw that use -p option. So probably it is not a bug.

Note You need to log in before you can comment on or make changes to this bug.