Bug 964194 - ClIentProxyBean need to handle toString method
ClIentProxyBean need to handle toString method
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: SwitchYard (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity medium
: ER3
: ---
Assigned To: Rob Cernich
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-17 09:38 EDT by Jiri Pechanec
Modified: 2015-08-02 19:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-06 10:27:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SWITCHYARD-1688 Major Closed ClIentProxyBean need to handle toString method 2014-06-16 19:49:07 EDT

  None (edit)
Description Jiri Pechanec 2013-05-17 09:38:44 EDT
Weld calls toString() methods for debugging purposes on CDI beans. Unfortunately if it tries to call it on SY Service bean an exception is thrown that can jeopardize the whole flow.

Here is an example of an exception thrown when a bean service is undeployed.

It is probably wise ti implement toString() to prived a meaningful information.

Also equals and hashCode might be considered.

15:23:15,782 WARN  [org.jboss.msc.service.fail] (MSC service thread 1-15) MSC000004: Failure during stop of service jboss.deployment.unit."bean-simple-service-client-test.jar".WeldBootstrapService: java.lang.reflect.UndeclaredThrowableException                                                                                        


        at org.jboss.weld.context.SerializableContextualInstanceImpl.toString(SerializableContextualInstanceImpl.java:60)
        at java.lang.String.valueOf(String.java:2854) [rt.jar:1.7.0_11]
        at java.lang.StringBuilder.append(StringBuilder.java:128) [rt.jar:1.7.0_11]
        at java.util.AbstractMap.toString(AbstractMap.java:523) [rt.jar:1.7.0_11]
        at java.lang.String.valueOf(String.java:2854) [rt.jar:1.7.0_11]
        at java.lang.StringBuilder.append(StringBuilder.java:128) [rt.jar:1.7.0_11]
        at org.jboss.weld.context.beanstore.ConcurrentHashMapBeanStore.toString(ConcurrentHashMapBeanStore.java:56)
        at org.jboss.weld.context.AbstractSharedContext.toString(AbstractSharedContext.java:74)
        at java.text.MessageFormat.subformat(MessageFormat.java:1271) [rt.jar:1.7.0_11]
        at java.text.MessageFormat.format(MessageFormat.java:860) [rt.jar:1.7.0_11]
        at java.text.Format.format(Format.java:157) [rt.jar:1.7.0_11]
        at java.text.MessageFormat.format(MessageFormat.java:836) [rt.jar:1.7.0_11]
        at ch.qos.cal10n.MessageConveyor.getMessage(MessageConveyor.java:89)
        at org.jboss.weld.logging.WeldMessageConveyor.getMessage(WeldMessageConveyor.java:66)
        at org.slf4j.cal10n.LocLogger.trace(LocLogger.java:75)
        at org.jboss.weld.context.AbstractContext.destroy(AbstractContext.java:135)
        at org.jboss.weld.context.AbstractSharedContext.destroy(AbstractSharedContext.java:61)
        at org.jboss.weld.context.AbstractSharedContext.invalidate(AbstractSharedContext.java:56)
        at org.jboss.weld.bootstrap.WeldBootstrap.shutdown(WeldBootstrap.java:463)
        at org.jboss.as.weld.WeldBootstrapService.stop(WeldBootstrapService.java:128)
        at org.jboss.msc.service.ServiceControllerImpl$StopTask.stopService(ServiceControllerImpl.java:1911) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
        at org.jboss.msc.service.ServiceControllerImpl$StopTask.run(ServiceControllerImpl.java:1874) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_11]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_11]
        at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_11]
Caused by: org.switchyard.component.bean.BeanComponentException: Bean Component invocation failure.  Operation 'toString' is not defined on Service 'SimpleService'.
        at org.switchyard.component.bean.ClientProxyBean$ClientProxyInvocationHandler.createExchange(ClientProxyBean.java:326)
        at org.switchyard.component.bean.ClientProxyBean$ClientProxyInvocationHandler.invoke(ClientProxyBean.java:281)
        ... 28 more
Comment 2 JBoss JIRA Server 2013-09-10 08:38:26 EDT
Keith Babo <kbabo@redhat.com> made a comment on jira SWITCHYARD-1688

pushed
Comment 3 Jiri Pechanec 2013-09-24 05:38:48 EDT
Verified in ER3
Comment 7 JBoss JIRA Server 2014-06-16 19:49:08 EDT
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1688 to Closed

Note You need to log in before you can comment on or make changes to this bug.