Bug 964243 - Knobs in oo-admin-ctl-gears should be admin-configurable
Knobs in oo-admin-ctl-gears should be admin-configurable
Status: CLOSED DEFERRED
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-17 11:54 EDT by Jeremy Eder
Modified: 2013-07-11 10:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-11 10:48:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Eder 2013-05-17 11:54:37 EDT
Description of problem:

Particularly these 2:

    @@DEFAULT_SLOTS = 5
    @@DEFAULT_GEAR_TIMEOUT = 200

Having these hard-coded means that starting up large amounts of apps takes longer than necessary.  It could be increased in that case.  Or maybe it should be lowered, because the gear size has been customized to be very large, and perhaps CPU-intensive.

GEAR_TIMEOUT should be customizable for similar reasons, perhaps very large JBoss apps that take a long time to get started.
Comment 2 Brenton Leanhardt 2013-07-11 10:42:25 EDT
/etc/init.d/openshift-gears calls this too.  The plan is to allow the services to be configurable.  Upstream will need to take systemd into account.  First we'll add options to oo-admin-ctl-gears to facilitate this.

We're going to track this the Origin trello board then close this as DEFERRED.
Comment 3 Luke Meyer 2013-07-11 10:48:56 EDT
Trello card is at https://trello.com/c/sHv9Ecf6

Note You need to log in before you can comment on or make changes to this bug.