Bug 964310 - firefox: automatically sends some data to Mozilla
firefox: automatically sends some data to Mozilla
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 968296
  Show dependency treegraph
 
Reported: 2013-05-17 15:53 EDT by Florian Weimer
Modified: 2013-05-29 08:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 968296 (view as bug list)
Environment:
Last Closed: 2013-05-29 07:58:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Weimer 2013-05-17 15:53:58 EDT
Description of problem:

Firefox displays the following message: "Firefox automatically sends some data to Mozilla so that we can improve your experience."

This is different from the previous prompt, which offered a clear yes/no choice the second time Firefox was started.  (Upstream no longer prompts and enables exfiltration by default, it seems.)

Version-Release number of selected component (if applicable):

firefox-21.0-2.fc18.x86_64

How reproducible:

Unclear.  I couldn't reproduce it in a sandbox.

Actual results:

Firefox suggest it shares data about my web surfing with Mozilla without my explicit consent.

Expected results:

Firefox does not share such data with Mozilla.
Comment 1 Florian Weimer 2013-05-17 16:35:58 EDT
I tested some upstream versions and found this:

Firefox 21 automatically enables "Firefox Health Report" and "Crash Report", without prompting the user.

Firefox 20 only enables "Crash Report".

Firefox 19 was the last version that prompts on the second start, but it still enables "Submit crash reports" even if the user opted out.  It's not clear to me if any data is sent for crash reports, sending SIGSEGV still results in a confirmation dialog.
Comment 2 Martin Stransky 2013-05-27 09:12:56 EDT
As for the health report, see https://blog.mozilla.org/metrics/fhr-faq. You can control it by  "datareporting.healthreport.uploadEnabled" or  "datareporting.healthreport.service.enabled" preferences in about:config.
Comment 3 Martin Stransky 2013-05-29 07:58:59 EDT
The crash report submit still has to be confirmed by user - so you can disable it.
Comment 4 Martin Stransky 2013-05-29 08:01:50 EDT
Another thing is that we don't have check boxes for that in Preferences/Advanced as the upstream firefox - we should investigate it.
Comment 5 Florian Weimer 2013-05-29 08:07:40 EDT
(In reply to Martin Stransky from comment #4)
> Another thing is that we don't have check boxes for that in
> Preferences/Advanced as the upstream firefox - we should investigate it.

I'm still concerned that the message may give users the impression that Firefox sends data to Mozilla even if it doesn't (by default).  We shouldn't claim that we have a privacy leak.

Note You need to log in before you can comment on or make changes to this bug.