Bug 964344 - "rhc port-forward" is not working while RoR scaled application is down
"rhc port-forward" is not working while RoR scaled application is down
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-17 19:25 EDT by Boris Mironov
Modified: 2015-05-14 19:18 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 17:32:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boris Mironov 2013-05-17 19:25:39 EDT
Description of problem:
One of the ways to take backup of MySQL database on OpenShift is to use "rhc port-forward". Most of the time it work except when application is down even though MYSQL is still up (since it is working on shared gear for scaled app"

Version-Release number of selected component (if applicable):
openshift.com as of May 17, 2013

How reproducible:
always for Rails scaled app

Steps to Reproduce:
1. rhc force-stop
2. rhc port-forward
3.
  
Actual results:

Password: ********
Checking available ports ... There are no available ports to forward for this application. Your application may be stopped.


Expected results:

Password: ********
Checking available ports ... There are no available ports to forward for this application. Your application may be stopped.


Additional info:

Even though application is down, there is a chance that database is still up. I would like to see port forwarding available for all active components
Comment 1 Jhon Honce 2013-05-20 17:32:12 EDT
In the future, the intended behaviour is to shutdown the database with the application.

Note You need to log in before you can comment on or make changes to this bug.