Bug 964364 - Error in file "/usr/share/applications/qtractor.desktop"
Error in file "/usr/share/applications/qtractor.desktop"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qtractor (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brendan Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-18 00:32 EDT by Olavi Ourson
Modified: 2013-05-28 23:00 EDT (History)
1 user (show)

See Also:
Fixed In Version: qtractor-0.5.8-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-28 20:50:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olavi Ourson 2013-05-18 00:32:37 EDT
Description of problem:

On updating blender get the following messages:

Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Error in file "/usr/share/applications/qtractor.desktop": "" is an invalid MIME type ("" does not contain a subtype)


Version-Release number of selected component (if applicable):
qtractor-0.5.8-1.fc19.x86_64

How reproducible:
Probably just running update-mime-database should do it.

Steps to Reproduce:
1. Install qtractor
2. Update/install blender
3. 
  
Actual results:
Get above errors/warnings

Expected results:
No errors/warnings

Additional info:
Seems that the error about qtractor.desktop is due to extra semicolon in the mimetype:

MimeType=application/x-qtractor-session;application/x-qtractor-template;application/x-qtractor-archive;;

Looking at the sources original qtractor.desktop.in seems ok, extra semicolon actually is added by sed in %prep step:

%prep
%setup -q -n %{name}-%{version}
%patch1 -p1
%patch2 -p1
sed -i -e 's|archive|archive;|' src/qtractor.desktop.in

Removing should rid the error.
Comment 1 Olavi Ourson 2013-05-18 00:34:22 EDT
Sorry, meant to write "Removing the sed command should rid the error."
Comment 2 Fedora Update System 2013-05-18 17:47:58 EDT
qtractor-0.5.8-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/qtractor-0.5.8-2.fc18
Comment 3 Fedora Update System 2013-05-18 17:48:10 EDT
qtractor-0.5.8-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/qtractor-0.5.8-2.fc19
Comment 4 Fedora Update System 2013-05-19 14:18:40 EDT
Package qtractor-0.5.8-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qtractor-0.5.8-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8604/qtractor-0.5.8-2.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-05-28 20:50:46 EDT
qtractor-0.5.8-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2013-05-28 23:00:55 EDT
qtractor-0.5.8-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.