This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 964370 - Crashes out every couple of minutes to an hour
Crashes out every couple of minutes to an hour
Status: CLOSED DUPLICATE of bug 980260
Product: Fedora
Classification: Fedora
Component: azureus (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: David Juran
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-18 01:59 EDT by Frank Murphy
Modified: 2013-10-03 09:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-03 09:44:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Grabbed from Terminal (19.35 KB, application/octet-stream)
2013-05-18 01:59 EDT, Frank Murphy
no flags Details
Workaround : service file (321 bytes, text/plain)
2013-06-03 09:03 EDT, Frank Murphy
no flags Details
azureus unit service file for autorestart (333 bytes, text/plain)
2013-10-03 08:56 EDT, Frank Murphy
no flags Details

  None (edit)
Description Frank Murphy 2013-05-18 01:59:28 EDT
Created attachment 749583 [details]
Grabbed from Terminal

Description of problem: Keeps crashing


Version-Release number of selected component (if applicable):
azureus-4.8.1.2-1.fc18.noarch
java-1.7.0-openjdk-1.7.0.19-2.3.9.5.fc18.x86_64

How reproducible: over many days


Steps to Reproduce:
1. in terminal type azureus
2.
3.
  
Actual results: crashes after a while


Expected results: no crash


Additional info: have also tested with upstream 5.x, terminates on start up.
Comment 1 Frank Murphy 2013-05-18 02:02:09 EDT
Have some crash info from Vuze 5.0 if any use?
Comment 2 Frank Murphy 2013-06-03 09:03:31 EDT
Created attachment 756296 [details]
Workaround : service file

This has helped me get aroung the crashes.
Comment 3 James 2013-10-02 20:33:46 EDT
(In reply to Frank Murphy from comment #2)
> Created attachment 756296 [details]
> Workaround : service file
> 
> This has helped me get aroung the crashes.

how do you use the work around, since I'm experiencing the same problem

James
Comment 4 Frank Murphy 2013-10-03 00:52:12 EDT
# In reply to James,
you can call it azureus.service (vuze.service, avuze.service)
modify to suite your own DE (gdm.kdm etc..) and User.
save the .service file to:
/etc/systemd/system/avuze.service

systemctl enable avuze.service 

The the service will auto-start azureus 3min after desktop login.
*I may have had a small rc.local entry going with that to search for pidof,
as torrent box is being rebuilt, can find it as yet.
Will reply with any updates.
Comment 5 David Juran 2013-10-03 08:14:50 EDT
My apologies, I've missed this bug report altogether )-:
From Frank's original description, it's not only azureus that crashes but the entire JVM. 
Do you have the core file available? If you don't enabling abrt will make it easy to capture one.
Comment 6 Frank Murphy 2013-10-03 08:37:37 EDT
Currently on F19,
Have 30mb of data, but it has added me to:
https://bugzilla.redhat.com/show_bug.cgi?id=980260
Don't know if it will clear the "needinfo"
Comment 7 Frank Murphy 2013-10-03 08:40:30 EDT
My bad 413.5 mb in the abrt crah folder for coredump 400+mb
Comment 8 Frank Murphy 2013-10-03 08:56:29 EDT
Created attachment 807075 [details]
azureus unit service file for autorestart

This is the updated version, doesn't require the pidof bit.
Comment 9 David Juran 2013-10-03 09:44:35 EDT
Bz 980260 seems like our bug, as also azureus is eclipse-based.
I'm closing this one as a duplicate.

*** This bug has been marked as a duplicate of bug 980260 ***

Note You need to log in before you can comment on or make changes to this bug.