Bug 964439 - SELinux is preventing /usr/bin/totem-video-thumbnailer from 'unlink' accesses on the file .gnome_desktop_thumbnail.W5W5WW.
SELinux is preventing /usr/bin/totem-video-thumbnailer from 'unlink' accesses...
Status: CLOSED DUPLICATE of bug 910988
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:e97fe0c6fcba9bdc9dca31c462d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-18 11:18 EDT by theo.jakaces
Modified: 2013-05-20 06:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 06:58:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description theo.jakaces 2013-05-18 11:18:25 EDT
Description of problem:
SELinux is preventing /usr/bin/totem-video-thumbnailer from 'unlink' accesses on the file .gnome_desktop_thumbnail.W5W5WW.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that totem-video-thumbnailer should be allowed unlink access on the .gnome_desktop_thumbnail.W5W5WW file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep totem-video-thu /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:user_tmp_t:s0
Target Objects                .gnome_desktop_thumbnail.W5W5WW [ file ]
Source                        totem-video-thu
Source Path                   /usr/bin/totem-video-thumbnailer
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           totem-3.4.3-1.fc17.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.10.0-169.fc17.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.8.12-100.fc17.i686 #1 SMP Wed
                              May 8 15:50:10 UTC 2013 i686 i686
Alert Count                   251
First Seen                    2013-05-18 16:10:04 CEST
Last Seen                     2013-05-18 17:07:57 CEST
Local ID                      0122cb9b-20e5-4908-bb0f-42c285473e07

Raw Audit Messages
type=AVC msg=audit(1368889677.461:281): avc:  denied  { unlink } for  pid=4682 comm="totem-video-thu" name=".gnome_desktop_thumbnail.W5W5WW" dev="sda6" ino=2309 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_tmp_t:s0 tclass=file


type=SYSCALL msg=audit(1368889677.461:281): arch=i386 syscall=unlink success=no exit=EACCES a0=868e140 a1=868e140 a2=4677bff4 a3=8836100 items=0 ppid=2362 pid=4682 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=2 tty=(none) comm=totem-video-thu exe=/usr/bin/totem-video-thumbnailer subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)

Hash: totem-video-thu,thumb_t,user_tmp_t,file,unlink

audit2allow

#============= thumb_t ==============
allow thumb_t user_tmp_t:file unlink;

audit2allow -R

#============= thumb_t ==============
allow thumb_t user_tmp_t:file unlink;


Additional info:
hashmarkername: setroubleshoot
kernel:         3.8.12-100.fc17.i686
type:           libreport

Potential duplicate: bug 910988
Comment 1 Miroslav Grepl 2013-05-20 06:58:46 EDT

*** This bug has been marked as a duplicate of bug 910988 ***

Note You need to log in before you can comment on or make changes to this bug.