Bug 964445 - [abrt] pyroom-0.4.1-5.fc17: locale.py:358:normalize:AttributeError: 'list' object has no attribute 'translate'
[abrt] pyroom-0.4.1-5.fc17: locale.py:358:normalize:AttributeError: 'list' ob...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pyroom (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
abrt_hash:87e048f2a72f928613d2b552b7a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-18 12:11 EDT by reescf
Modified: 2013-08-01 00:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 00:55:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (867 bytes, text/plain)
2013-05-18 12:11 EDT, reescf
no flags Details
File: core_backtrace (544 bytes, text/plain)
2013-05-18 12:11 EDT, reescf
no flags Details
File: environ (2.03 KB, text/plain)
2013-05-18 12:11 EDT, reescf
no flags Details
File: smolt_data (3.63 KB, text/plain)
2013-05-18 12:11 EDT, reescf
no flags Details

  None (edit)
Description reescf 2013-05-18 12:11:12 EDT
Description of problem:
I tried to start pyroom.

[Related: I then tried to authenticate to use abrt but it wants a password for a keyring I've never heard of and keeps saying Secret Service is not available!]

Version-Release number of selected component:
pyroom-0.4.1-5.fc17

Additional info:
cmdline:        /usr/bin/python /usr/bin/pyroom
dso_list:       python-libs-2.7.3-7.2.fc17.x86_64
executable:     /usr/bin/pyroom
kernel:         3.8.3-103.fc17.x86_64
uid:            1000
ureports_counter: 1

Truncated backtrace:
locale.py:358:normalize:AttributeError: 'list' object has no attribute 'translate'

Traceback (most recent call last):
  File "/usr/bin/pyroom", line 35, in <module>
    import sys, PyRoom.cmdline
  File "/usr/lib/python2.7/site-packages/PyRoom/__init__.py", line 34, in <module>
    fallback=True)
  File "/usr/lib64/python2.7/gettext.py", line 467, in translation
    mofiles = find(domain, localedir, languages, all=1)
  File "/usr/lib64/python2.7/gettext.py", line 439, in find
    for nelang in _expand_lang(lang):
  File "/usr/lib64/python2.7/gettext.py", line 132, in _expand_lang
    locale = normalize(locale)
  File "/usr/lib64/python2.7/locale.py", line 358, in normalize
    fullname = localename.translate(_ascii_lower_map)
AttributeError: 'list' object has no attribute 'translate'

Local variables in innermost frame:
localename: ['cy_GB:cy:en_GB:en']
Comment 1 reescf 2013-05-18 12:11:15 EDT
Created attachment 749656 [details]
File: backtrace
Comment 2 reescf 2013-05-18 12:11:17 EDT
Created attachment 749657 [details]
File: core_backtrace
Comment 3 reescf 2013-05-18 12:11:19 EDT
Created attachment 749658 [details]
File: environ
Comment 4 reescf 2013-05-18 12:11:21 EDT
Created attachment 749659 [details]
File: smolt_data
Comment 5 reescf 2013-05-18 12:21:46 EDT
Output from locale:

LANG=cy_GB.UTF-8
LC_CTYPE="cy_GB.UTF-8"
LC_NUMERIC="cy_GB.UTF-8"
LC_TIME="cy_GB.UTF-8"
LC_COLLATE=C
LC_MONETARY="cy_GB.UTF-8"
LC_MESSAGES="cy_GB.UTF-8"
LC_PAPER="cy_GB.UTF-8"
LC_NAME="cy_GB.UTF-8"
LC_ADDRESS="cy_GB.UTF-8"
LC_TELEPHONE="cy_GB.UTF-8"
LC_MEASUREMENT="cy_GB.UTF-8"
LC_IDENTIFICATION="cy_GB.UTF-8"
LC_ALL=

Output from echo $LANGUAGE:

cy_GB:cy:en_GB:en
Comment 6 reescf 2013-05-18 12:41:23 EDT
Setting LANGUAGE to an empty string in a subshell lets pyroom start.
Comment 7 reescf 2013-05-24 07:03:28 EDT
On Arch Linux, pyroom runs fine without the work around even though LANGUAGE is set to the same value as on Fedora and my locale settings are all identical.
Comment 8 Fedora End Of Life 2013-07-03 20:49:29 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 9 Fedora End Of Life 2013-08-01 00:55:56 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.