Bug 964499 - ami-9d543df4 RHEL 5.6 x86_64 us-east-1
ami-9d543df4 RHEL 5.6 x86_64 us-east-1
Status: CLOSED WONTFIX
Product: Cloud Image Validation
Classification: Red Hat
Component: images (Show other bugs)
RHEL5.6
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: mkovacik
mkovacik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-18 20:11 EDT by Vitaly Kuznetsov
Modified: 2013-05-29 10:00 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 10:00:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ami-9d543df4.yaml (35.98 KB, text/yaml)
2013-05-18 20:11 EDT, Vitaly Kuznetsov
no flags Details

  None (edit)
Description Vitaly Kuznetsov 2013-05-18 20:11:19 EDT

    
Comment 1 Vitaly Kuznetsov 2013-05-18 20:11:22 EDT
Created attachment 749822 [details]
ami-9d543df4.yaml
Comment 2 Vitaly Kuznetsov 2013-05-18 20:11:28 EDT
Validation failed for ami-9d543df4 in us-east-1 product: RHEL, version: 5.6, arch: x86_64

m1.small
test stage1:testcase_01_bash_history succeeded
test stage1:testcase_02_ipv6 succeeded
test stage1:testcase_03_chkconfig succeeded
test stage1:testcase_04_cloud_firstboot succeeded
test stage1:testcase_05_grub succeeded
test stage1:testcase_06_inittab succeeded
test stage1:testcase_07_libc6_xen_conf succeeded
test stage1:testcase_08_memory succeeded
test stage1:testcase_09_nameserver succeeded
test stage1:testcase_10_networking succeeded
test stage1:testcase_11_package_set failed
--->
	command: rpm -qa --queryformat '%{NAME},' && echo
	match: .*
(.*),
.*
	result: passed
	value: ['mailcap,cracklib-dicts,zlib,mktemp,db4,libcap,libacl,keyutils-libs,libgpg-error,libXau,libfontenc,slang,gmp,mingetty,mailx,wireless-tools,termcap,info,nss,gawk,libidn,iptables,less,vim-common,groff,tcl,iproute,jwhois,udftools,mgetty,mtr,fbset,attr,compat-db,dosfstools,pam_passwdqc,setserial,symlinks,xorg-x11-filesystem,xorg-x11-font-utils,libXpm,libXinerama,redhat-logos,bitstream-vera-fonts,man-pages-ko,man-pages-cs,rootfiles,words,device-mapper,apr,e2fsprogs,device-mapper-multipath,MAKEDEV,tmpwatch,nss_db,aspell-pt,aspell-pl,coreutils,krb5-libs,newt,util-linux,libxml2-python,rpm-libs,pango,mx,dmraid,python-dmidecode,pycairo,curl,cups-libs,fipscheck,python-sqlite,python-numeric,alsa-lib,nss_ldap,bind-utils,MySQL-python,krb5-workstation,autofs,pam_krb5,screen,nmap,tux,htmlview,libgcj,rhnlib,w3m,yum-utils,ruby-rdoc,Deployment_Guide-ru-RU,Deployment_Guide-it-IT,Deployment_Guide-ja-JP,python-setuptools,policycoreutils,gjdoc,rhnsd,openssh-clients,mod_authz_ldap,mod_python,vixie-cron,rng-utils,xinetd,xorg-x11-xfs,kernel-xen,fonts-chinese,kudzu,rhn-setup,gpg-pubkey,libgcc,filesystem,basesystem,nash,tzdata,glibc,chkconfig,popt,libstdc++,expat,cyrus-sasl-lib,bzip2-libs,atk,libattr,pcre,elfutils-libelf,libICE,libusb,libsysfs,perl,libgcrypt,libtiff,dmidecode,unixODBC,perl-BSD-Resource,perl-String-CRC32,file,libtool-ltdl,ethtool,pkgconfig,libFS,libvolume_id,hesiod,perl-URI,libtermcap,ncurses,grep,nspr,libsepol,sed,libxml2,ttmkfdir,diffutils,procps,libXfont,gpm,gzip,iptables-ipv6,hmaccalc,cpio,cpp,desktop-file-utils,gamin,lm_sensors,mozldap,crash,nss-tools,ftp,lftp,ed,time,telnet,nc,unzip,sysfsutils,rsync,cyrus-sasl-plain,beecrypt,lslk,unix2dos,ncompress,hdparm,traceroute,libaio,pam_smb,tree,setarch,jpackage-utils,libX11,libXrender,libXt,libXrandr,libXfixes,libXaw,libXi,redhat-menus,redhat-release,glibc-devel,libXp,grub,man-pages-it,man-pages-es,man-pages-pl,man-pages-de,man-pages-ru,man-pages,gcc,shadow-utils,e2fsprogs-libs,findutils,logrotate,libutempter,tar,psmisc,cryptsetup-luks,lvm2,net-tools,aspell-en,parted,patch,vim-enhanced,kernel-xen-devel,aspell-de,aspell-fr,aspell-it,aspell-es,python,pam,openldap,cairo,rpm,udev,python-libs,fipscheck-lib,dbus-libs,mysql,rpm-python,dbus-python,libsemanage,libXft,libuser,m2crypto,pygobject2,dbus,passwd,authconfig,gamin-python,ntsysv,gd,samba-common,gnupg,neon,iscsi-initiator-utils,net-snmp-libs,ruby-libs,pyOpenSSL,audit-libs-python,libselinux-python,python-elementtree,tcsh,nscd,cracklib,mtools,subversion,samba-client,postgresql-python,xterm,openswan,prelink,man,sudo,pkinit-nss,cyrus-sasl-gssapi,pam_pkcs11,at,tcpdump,cyrus-sasl-md5,readahead,audit,ksh,python-iniparse,gtk2,pygtk2,pygtk2-libglade,ruby-irb,yum,sgml-common,psgml,yum-updateonboot,yum-security,system-config-securitylevel,Deployment_Guide-ko-KR,Deployment_Guide-de-DE,Deployment_Guide-fr-FR,Deployment_Guide-zh-TW,Deployment_Guide-pt-BR,sos,liberation-fonts,logwatch,httpd,java-1.4.2-gcj-compat,antlr,mcstrans,exim,selinux-policy,mutt,openssh-server,setools,webalizer,mod_perl,dhclient,quota,vsftpd,acpid,dhcpv6-client,yum-updatesd,chkfontpath,module-init-tools,hwdata,usbutils,fonts-KOI8-R,fonts-japanese,fonts-KOI8-R-75dpi,hal,pm-utils,yum-rhn-plugin,system-config-network-tui,firstboot-tui,gpg-pubkey,setup,kernel-headers,glibc-common,glib2,audit-libs,tcp_wrappers,libpng,libjpeg,libSM,gdbm,gnutls,zip,perl-DBI,libXdmcp,sgpio,libart_lgpl,checkpolicy,bash,readline,freetype,sqlite,binutils,libgomp,bzip2,svrcore,make,iputils,iptstate,bc,nano,dialog,cpuspeed,acl,libicu,dos2unix,finger,compat-libstdc++-33,pax,crontabs,libXext,libXmu,libXcursor,libXtst,glibc-headers,anacron,man-pages-fr,redhat-release-notes,man-pages-ja,libselinux,aspell,kpartx,libselinux-utils,device-mapper-event,vim-minimal,mlocate,lsof,aspell-cs,aspell-ru,openssl,fontconfig,postgresql-libs,rhpl,apr-util,dbus-glib,system-config-securitylevel-tui,SysVinit,rsyslog,usermode,which,libsmbclient,bind-libs,distcache,ruby,yum-metadata-parser,gettext,dmraid-events,net-snmp,setuptool,mysql-connector-odbc,postgresql-odbc,openldap-clients,pam_ccreds,stunnel,libhugetlbfs,conman,hicolor-icon-theme,libglade2,python-urlgrabber,pinfo,yum-fastestmirror,Deployment_Guide-en-US,Deployment_Guide-zh-CN,Deployment_Guide-es-ES,rhel-instnum,initscripts,openssh,kbd,rhn-check,postgresql-jdbc,mod_ssl,postgresql,irqbalance,selinux-policy-targeted,mkinitrd,pciutils,fonts-korean,fonts-KOI8-R-100dpi,rhn-client-tools,rh-amazon-rhui-client']
<---
--->
	comment: Newly introduced packages: []
	result: passed
<---
--->
	comment: some packages are missing: ['m4', 'redhat-lsb']
	result: failed
<---
test stage1:testcase_12_passwd_group succeeded
test stage1:testcase_13_resize2fs succeeded
test stage1:testcase_14_host_details succeeded
test stage1:testcase_15_rhel_version succeeded
test stage1:testcase_16_selinux succeeded
test stage1:testcase_17_shells succeeded
test stage1:testcase_18_sshd failed
--->
	command: rpm -q systemd > /dev/null && echo True || echo False
	result: passed
	value: False
<---
--->
	command: chkconfig --list sshd | grep '0:off[[:space:]]*1:off[[:space:]]*2:on[[:space:]]*3:on[[:space:]]*4:on[[:space:]]*5:on[[:space:]]*6:off'
	result: passed
<---
--->
	command: service sshd status | grep running
	result: passed
<---
--->
	actual: 1
	command: grep 'PasswordAuthentication no' /etc/ssh/sshd_config
	result: failed
<---
test stage1:testcase_19_rhn_system_id succeeded
test stage1:testcase_20_auditd succeeded
test stage1:testcase_21_disk_size_format succeeded
test stage1:testcase_22_gpg_keys succeeded
test stage1:testcase_23_syslog succeeded
test stage1:testcase_24_yum_plugin succeeded
test stage1:testcase_25_uname failed
--->
	command: uname -r | sed 's,\.el5xen,.el5,'
	result: passed
	value: 2.6.18-238.49.1.el5
<---
--->
	command: rpm -q --last kernel-xen | sed -e 's,^kernel-xen-,,' -e 's,[[:space:]].*$,,' | head -1
	result: passed
	value: 2.6.18-238.49.1.el5
<---
--->
	command: uname -o
	result: passed
	value: GNU/Linux
<---
--->
	command: [ 2.6.18-238.49.1.el5 = 2.6.18-238.49.1.el5 ]
	result: passed
<---
--->
	command: [ GNU/Linux = 'GNU/Linux' ]
	result: passed
<---
--->
	actual: 2
	command: grep UPDATEDEFAULT=yes /etc/sysconfig/kernel
	result: failed
<---
--->
	actual: 2
	command: grep DEFAULTKERNEL=kernel /etc/sysconfig/kernel
	result: failed
<---
test stage1:testcase_26_verify_rpms succeeded
test stage1:testcase_28_iptables succeeded
test stage1:testcase_33_userdata succeeded
test stage1:testcase_34_cpu succeeded
test stage1:testcase_360_ebs succeeded
test stage1:testcase_39_root_is_locked succeeded
test stage1:testcase_40_selinux_context succeeded
test stage1:testcase_50_yum_package_install succeeded
test stage1:testcase_55_yum_group_install succeeded
test stage1:testcase_61_yum_proxy succeeded
test stage1:testcase_99_reboot succeeded
test stage2:testcase_08_memory succeeded
test stage2:testcase_25_uname failed
--->
	command: uname -r | sed 's,\.el5xen,.el5,'
	result: passed
	value: 2.6.18-238.49.1.el5
<---
--->
	command: rpm -q --last kernel-xen | sed -e 's,^kernel-xen-,,' -e 's,[[:space:]].*$,,' | head -1
	result: passed
	value: 2.6.18-238.49.1.el5
<---
--->
	command: uname -o
	result: passed
	value: GNU/Linux
<---
--->
	command: [ 2.6.18-238.49.1.el5 = 2.6.18-238.49.1.el5 ]
	result: passed
<---
--->
	command: [ GNU/Linux = 'GNU/Linux' ]
	result: passed
<---
--->
	actual: 2
	command: grep UPDATEDEFAULT=yes /etc/sysconfig/kernel
	result: failed
<---
--->
	actual: 2
	command: grep DEFAULTKERNEL=kernel /etc/sysconfig/kernel
	result: failed
<---

Note You need to log in before you can comment on or make changes to this bug.