Bug 964647 - webadmin [TEXT]: when we try to import a vm that is depended on a template which no longer exists in both setup or export domain we get an unclear error
webadmin [TEXT]: when we try to import a vm that is depended on a template wh...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.2.0
x86_64 Linux
unspecified Severity high
: ---
: 3.3.0
Assigned To: Maor
yeylon@redhat.com
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-19 07:09 EDT by Dafna Ron
Modified: 2016-04-18 02:53 EDT (History)
11 users (show)

See Also:
Fixed In Version: is6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:13:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
scohen: needinfo+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16731 None None None Never

  None (edit)
Description Dafna Ron 2013-05-19 07:09:49 EDT
Description of problem:

when we try to import a vm that it's template no longer exists in both setup and export domain we are getting a message which does not really convey to the user that the vm cannot be used without the template and that the template does not exist in both export and setup. 

this is the warning that we get for a vm that has the template in the export domain but not the setup: Some imported VMs depend on one or more templates which are not available in the system. Therefore you must Import those VMs with 'collapse snapshots', another option is to Import missing templates first and then try import the VMs again

this is the warning that we get for a vm that it's template no longer exist at all: 

One of the templates cannot be found in the system, VM(s) cannot be imported

Version-Release number of selected component (if applicable):

sf17

How reproducible:

100%

Steps to Reproduce:
1. export a vm depended on template and remove the template from the setup and export domain
2. try to import
3.
  
Actual results:

we are getting an error: 

One of the templates cannot be found in the system, VM(s) cannot be imported

Expected results:

1. it took me about 30 minutes to realize that the template was removed from the setup and the export domain (mainly because I have a template with a similiar name but a different UUID). 
2. the use of the word "system" in case the template does not exist only in the setup and in case the template does not exist al all is very confusing... 

Additional info:
Comment 1 Maor 2013-07-09 08:21:12 EDT
The GUI message of "One of the templates cannot be found in the system, VM(s) cannot be imported" is executed at ImportVmModel#onSuccess

We can add the missing UUID in the warnning message, but I'm not sure the user seeing guid values is a good user experience...

The other approach is to move the validation from the GUI to the backend, but that could have impact on latency (network to the server and back)
Comment 2 Sean Cohen 2013-07-11 03:21:06 EDT
I believe this can be solved with better text (instead of adding the missing UUID or move the validation to the backend), something like:

"VM(s) cannot be imported: One of the templates cannot be found. 
Please verify that the template exists in both setup and export domain."
Comment 3 Maor 2013-07-11 12:05:53 EDT
Merged with the suggested solution by Sean
Comment 4 vvyazmin@redhat.com 2013-07-22 08:39:47 EDT
No issues are found

Verified, tested on RHEVM 3.3 - IS6 environment:

RHEVM: rhevm-3.3.0-0.9.master.el6ev.noarch
VDSM: vdsm-4.12.0-rc1.12.git8ee6885.el6.x86_64
LIBVIRT: libvirt-0.10.2-18.el6_4.9.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.355.el6_4.5.x86_64
SANLOCK: sanlock-2.6-2.el6.x86_64
Comment 7 Itamar Heim 2014-01-21 17:13:28 EST
Closing - RHEV 3.3 Released
Comment 8 Itamar Heim 2014-01-21 17:21:21 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.