Bug 964658 - SELinux is preventing /usr/bin/gnome-keyring-daemon from 'write' accesses on the file user.
SELinux is preventing /usr/bin/gnome-keyring-daemon from 'write' accesses on ...
Status: CLOSED DUPLICATE of bug 964954
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:0c53658c19d553667098afeeb93...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-19 08:12 EDT by vinesh teotia
Modified: 2013-05-20 04:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 04:10:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vinesh teotia 2013-05-19 08:12:48 EDT
Description of problem:
SELinux is preventing /usr/bin/gnome-keyring-daemon from 'write' accesses on the file user.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that gnome-keyring-daemon should be allowed write access on the user file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep gnome-keyring-d /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:config_home_t:s0
Target Objects                user [ file ]
Source                        gnome-keyring-d
Source Path                   /usr/bin/gnome-keyring-daemon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           telepathy-mission-control-5.14.1-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-44.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.2-301.fc19.x86_64 #1 SMP Mon
                              May 13 12:36:24 UTC 2013 x86_64 x86_64
Alert Count                   3
First Seen                    2013-05-13 16:51:09 IST
Last Seen                     2013-05-16 12:43:33 IST
Local ID                      d0c9ddcb-3133-4a28-88a6-30f8db3371d3

Raw Audit Messages
type=AVC msg=audit(1368688413.969:498): avc:  denied  { write } for  pid=9409 comm="mission-control" name="user" dev="tmpfs" ino=75704 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:config_home_t:s0 tclass=file


type=SYSCALL msg=audit(1368688413.969:498): arch=x86_64 syscall=open success=yes exit=E2BIG a0=a61a00 a1=42 a2=180 a3=7fff102182d0 items=0 ppid=1 pid=9409 auid=4294967295 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 ses=4294967295 tty=(none) comm=mission-control exe=/usr/libexec/mission-control-5 subj=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 key=(null)

Hash: gnome-keyring-d,xdm_dbusd_t,config_home_t,file,write

audit2allow

#============= xdm_dbusd_t ==============
allow xdm_dbusd_t config_home_t:file write;

audit2allow -RYou must regenerate interface info by running /usr/bin/sepolgen-ifgen


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.2-301.fc19.x86_64
type:           libreport

Potential duplicate: bug 964292
Comment 1 Miroslav Grepl 2013-05-20 04:10:56 EDT

*** This bug has been marked as a duplicate of bug 964954 ***

Note You need to log in before you can comment on or make changes to this bug.