Bug 964662 - SELinux is preventing /usr/libexec/mission-control-5 from 'write' accesses on the directory /var/lib/gdm/.local/share/telepathy/mission-control.
SELinux is preventing /usr/libexec/mission-control-5 from 'write' accesses on...
Status: CLOSED DUPLICATE of bug 964660
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:670268636ba16e91815d1315021...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-19 08:15 EDT by vinesh teotia
Modified: 2013-05-20 04:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 04:40:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vinesh teotia 2013-05-19 08:15:44 EDT
Description of problem:
SELinux is preventing /usr/libexec/mission-control-5 from 'write' accesses on the directory /var/lib/gdm/.local/share/telepathy/mission-control.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that mission-control-5 should be allowed write access on the mission-control directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep mission-control /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:xdm_var_lib_t:s0
Target Objects                /var/lib/gdm/.local/share/telepathy/mission-
                              control [ dir ]
Source                        mission-control
Source Path                   /usr/libexec/mission-control-5
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           telepathy-mission-control-5.14.1-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-44.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.2-301.fc19.x86_64 #1 SMP Mon
                              May 13 12:36:24 UTC 2013 x86_64 x86_64
Alert Count                   3
First Seen                    2013-05-13 16:51:09 IST
Last Seen                     2013-05-16 12:43:33 IST
Local ID                      3f672c43-f5b9-4d09-8a7a-1850b2ecd10a

Raw Audit Messages
type=AVC msg=audit(1368688413.767:494): avc:  denied  { write } for  pid=9409 comm="mission-control" name="mission-control" dev="dm-2" ino=2234645 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xdm_var_lib_t:s0 tclass=dir


type=AVC msg=audit(1368688413.767:494): avc:  denied  { add_name } for  pid=9409 comm="mission-control" name="accounts-goa.cfg.U32KXW" scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xdm_var_lib_t:s0 tclass=dir


type=AVC msg=audit(1368688413.767:494): avc:  denied  { create } for  pid=9409 comm="mission-control" name="accounts-goa.cfg.U32KXW" scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xdm_var_lib_t:s0 tclass=file


type=AVC msg=audit(1368688413.767:494): avc:  denied  { write } for  pid=9409 comm="mission-control" path="/var/lib/gdm/.local/share/telepathy/mission-control/accounts-goa.cfg.U32KXW" dev="dm-2" ino=2232340 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xdm_var_lib_t:s0 tclass=file


type=SYSCALL msg=audit(1368688413.767:494): arch=x86_64 syscall=open success=yes exit=EIO a0=a1d9a0 a1=c2 a2=1b6 a3=0 items=0 ppid=9408 pid=9409 auid=4294967295 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 ses=4294967295 tty=(none) comm=mission-control exe=/usr/libexec/mission-control-5 subj=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 key=(null)

Hash: mission-control,xdm_dbusd_t,xdm_var_lib_t,dir,write

audit2allow

#============= xdm_dbusd_t ==============
allow xdm_dbusd_t xdm_var_lib_t:dir { write add_name };
allow xdm_dbusd_t xdm_var_lib_t:file { write create };

audit2allow -RYou must regenerate interface info by running /usr/bin/sepolgen-ifgen


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.2-301.fc19.x86_64
type:           libreport

Potential duplicate: bug 862152
Comment 1 Miroslav Grepl 2013-05-20 04:40:31 EDT

*** This bug has been marked as a duplicate of bug 964660 ***

Note You need to log in before you can comment on or make changes to this bug.