Bug 964671 - SELinux is preventing /usr/bin/gnome-keyring-daemon from 'execute_no_trans' accesses on the file /usr/bin/gnome-keyring-daemon.
SELinux is preventing /usr/bin/gnome-keyring-daemon from 'execute_no_trans' a...
Status: CLOSED DUPLICATE of bug 964292
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:9c4b4a89f09d01d86f788ded520...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-19 08:22 EDT by vinesh teotia
Modified: 2013-05-20 03:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 03:52:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vinesh teotia 2013-05-19 08:22:57 EDT
Description of problem:
SELinux is preventing /usr/bin/gnome-keyring-daemon from 'execute_no_trans' accesses on the file /usr/bin/gnome-keyring-daemon.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that gnome-keyring-daemon should be allowed execute_no_trans access on the gnome-keyring-daemon file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep gnome-keyring-d /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:gkeyringd_exec_t:s0
Target Objects                /usr/bin/gnome-keyring-daemon [ file ]
Source                        gnome-keyring-d
Source Path                   /usr/bin/gnome-keyring-daemon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gnome-keyring-3.8.2-1.fc19.x86_64
Target RPM Packages           gnome-keyring-3.8.2-1.fc19.x86_64
Policy RPM                    selinux-policy-3.12.1-42.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.1-301.fc19.x86_64 #1 SMP Wed
                              May 8 18:02:34 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-13 16:51:09 IST
Last Seen                     2013-05-13 16:51:09 IST
Local ID                      1f2034e5-dc4c-40d4-b6c1-b7d3670b7ad2

Raw Audit Messages
type=AVC msg=audit(1368444069.131:458): avc:  denied  { execute_no_trans } for  pid=2700 comm="dbus-daemon" path="/usr/bin/gnome-keyring-daemon" dev="dm-2" ino=923689 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:gkeyringd_exec_t:s0 tclass=file


type=SYSCALL msg=audit(1368444069.131:458): arch=x86_64 syscall=execve success=yes exit=0 a0=7f10d4d18290 a1=7f10d4d183e0 a2=7f10d4d184d0 a3=7f10d385cb10 items=0 ppid=2699 pid=2700 auid=4294967295 uid=42 gid=42 euid=42 suid=42 fsuid=42 egid=42 sgid=42 fsgid=42 ses=4294967295 tty=(none) comm=gnome-keyring-d exe=/usr/bin/gnome-keyring-daemon subj=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 key=(null)

Hash: gnome-keyring-d,xdm_dbusd_t,gkeyringd_exec_t,file,execute_no_trans

audit2allow

#============= xdm_dbusd_t ==============
allow xdm_dbusd_t gkeyringd_exec_t:file execute_no_trans;

audit2allow -RYou must regenerate interface info by running /usr/bin/sepolgen-ifgen


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.2-301.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-05-20 03:52:08 EDT

*** This bug has been marked as a duplicate of bug 964292 ***

Note You need to log in before you can comment on or make changes to this bug.