Bug 964672 - SELinux is preventing dbus-daemon from read, open access on the file /usr/bin/gnome-keyring-daemon.
SELinux is preventing dbus-daemon from read, open access on the file /usr/bin...
Status: CLOSED DUPLICATE of bug 964954
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:84f68e35e6572316f6ec8613dd7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-19 08:23 EDT by vinesh teotia
Modified: 2013-05-20 04:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 04:11:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vinesh teotia 2013-05-19 08:23:40 EDT
Description of problem:
SELinux is preventing dbus-daemon from read, open access on the file /usr/bin/gnome-keyring-daemon.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that dbus-daemon should be allowed read open access on the gnome-keyring-daemon file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep dbus-daemon /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:gkeyringd_exec_t:s0
Target Objects                /usr/bin/gnome-keyring-daemon [ file ]
Source                        dbus-daemon
Source Path                   dbus-daemon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           gnome-keyring-3.8.2-1.fc19.x86_64
Policy RPM                    selinux-policy-3.12.1-42.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.1-301.fc19.x86_64 #1 SMP Wed
                              May 8 18:02:34 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-13 16:51:09 IST
Last Seen                     2013-05-13 16:51:09 IST
Local ID                      688d2192-0249-4533-b5ba-76f054887842

Raw Audit Messages
type=AVC msg=audit(1368444069.131:458): avc:  denied  { read open } for  pid=2700 comm="dbus-daemon" path="/usr/bin/gnome-keyring-daemon" dev="dm-2" ino=923689 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:gkeyringd_exec_t:s0 tclass=file


Hash: dbus-daemon,xdm_dbusd_t,gkeyringd_exec_t,file,read,open

audit2allow

#============= xdm_dbusd_t ==============
allow xdm_dbusd_t gkeyringd_exec_t:file { read open };

audit2allow -RYou must regenerate interface info by running /usr/bin/sepolgen-ifgen


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.2-301.fc19.x86_64
type:           libreport

Potential duplicate: bug 768743
Comment 1 Miroslav Grepl 2013-05-20 04:11:05 EDT

*** This bug has been marked as a duplicate of bug 964954 ***

Note You need to log in before you can comment on or make changes to this bug.