Bug 964683 - libreoffice calc gives input/output error when reading xlsx file
libreoffice calc gives input/output error when reading xlsx file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
18
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-19 09:53 EDT by Brent R Brian
Modified: 2013-07-11 04:51 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-11 04:51:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dialog box screen shot (8.66 KB, image/png)
2013-05-19 09:53 EDT, Brent R Brian
no flags Details
export of mutual fund research data in xlsx format (161.85 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-05-19 09:54 EDT, Brent R Brian
no flags Details

  None (edit)
Description Brent R Brian 2013-05-19 09:53:25 EDT
Created attachment 750045 [details]
dialog box screen shot

Description of problem:

  Dialog [General error: general input/output error]

How reproducible:

  Every time

Steps to Reproduce:

  Open attached file

Actual results:

  Dialog [General error: general input/output error]

Expected results:

  Open spreadsheet
Comment 1 Brent R Brian 2013-05-19 09:54:27 EDT
Created attachment 750046 [details]
export of mutual fund research data in xlsx format
Comment 2 David Tardon 2013-07-11 04:51:44 EDT
Sorry for late response, this fell through the cracks...

The file is not actually xslx (OpenXML), but SpreadsheetML produced by MS Office 2003. The problem is that the XML contains character entities ( ), which cannot be resolved without a DTD. Worse, it also contains unescaped ampersands, so it is not even well-formed XML. The XML parser rightfully rejects it.

Note You need to log in before you can comment on or make changes to this bug.